Long title with no spaces cause column misalignment in files grid

Bug #365266 reported by Jason Lantz on 2009-04-22
4
Affects Status Importance Assigned to Milestone
KARL3
Medium
Balazs Ree

Bug Description

The jquery grid for the files section in communities does not work well with long values that cannot be wrapped to a new line in the browser. In a normal HTML table, similar behavior would occur but the column headers would still match up with the columns below them. The column headers should stay consistent with the content in the cells of the grid.

This issue same issue is also causing problems in the people directory for columns such as website where a long url will destroy the alignment of the headers

To reproduce:

Add a file with a title TestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTest and then look at the grid.

Right, our approach for this has been to make sure the displayed value
is chopped to some reasonable value, with a title attribute on the
HTML node to display in hovering. We did that in KARL2 for any place
that was space constrained.

--Paul

On Apr 22, 2009, at 4:23 PM, Jason Lantz wrote:

> Public bug reported:
>
> The jquery grid for the files section in communities does not work
> well
> with long values that cannot be wrapped to a new line in the browser.
> In a normal HTML table, similar behavior would occur but the column
> headers would still match up with the columns below them. The column
> headers should stay consistent with the content in the cells of the
> grid.
>
> This issue same issue is also causing problems in the people directory
> for columns such as website where a long url will destroy the
> alignment
> of the headers
>
> To reproduce:
>
> Add a file with a title
> TestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTest
> and then look at the grid.
>
> ** Affects: karl3
> Importance: Undecided
> Status: New
>
> --
> Long title with no spaces cause column misalignment in files grid
> https://bugs.launchpad.net/bugs/365266
> You received this bug notification because you are subscribed to
> KARL3.
>
> Status in Porting KARL to a new architecture: New
>
> Bug description:
> The jquery grid for the files section in communities does not work
> well with long values that cannot be wrapped to a new line in the
> browser. In a normal HTML table, similar behavior would occur but
> the column headers would still match up with the columns below
> them. The column headers should stay consistent with the content in
> the cells of the grid.
>
> This issue same issue is also causing problems in the people
> directory for columns such as website where a long url will destroy
> the alignment of the headers
>
> To reproduce:
>
> Add a file with a title
> TestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTestTest
> and then look at the grid.

Paul Everitt (paul-agendaless) wrote :

I'll assign this to Balazs, as some of the evaluation of possibilities might depend on 365280.

If worse comes to worse, we can use KARL2 strategies, for example, what we do in portlets for long titles.

Changed in karl3:
assignee: nobody → ree
importance: Undecided → Medium
milestone: none → m11
Balazs Ree (ree) on 2009-04-24
Changed in karl3:
status: New → In Progress
Balazs Ree (ree) wrote :

Paul wrote:

"I'll assign this to Balazs, as some of the evaluation of possibilities might depend on 365280."

I believe it's the other way around. The column width setting was clearly underimplemented. Now it's done properly.
Issue 365280 couldn't be evaluated before this is working.

Changed in karl3:
status: In Progress → Fix Committed
Changed in karl3:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers