Migrate communities with correct roster

Bug #358681 reported by Paul Everitt on 2009-04-09
2
Affects Status Importance Assigned to Milestone
KARL3
Low
claytron

Bug Description

Migrate communities, resulting in a correct listing of:

- creator

- moderators

- members

This likely means the first step is to get users into the system, and possibly profiles.

Paul Everitt (paul-agendaless) wrote :

This is a pretty basic step, but one that will probably exercise a good bit of the challenge.

Changed in karl3:
assignee: nobody → clayton-sixfeetup
importance: Undecided → Medium
milestone: none → m9
Paul Everitt (paul-agendaless) wrote :

Thursday was Clayton's day, moving to next week.

Changed in karl3:
milestone: m9 → m10
claytron (clayton-sixfeetup) wrote :

The importer has been set up to set the creator, roster and moderators. Unfortunately, the current GS export from Karl2 does not export the members from the communities. There is a [Members] section of the .properties file, but it is blank. I will need to find out if that is a bug or if it was never implemented.

(Commenting on correct issue, misfired earlier.)

I just talked to Tres about this. He thinks there is a package that
handles this. He's a subscriber on this LP issue, but you might want
to ping him directly for more info as you get closer to Thursday.

--Paul

On Apr 13, 2009, at 9:39 AM, claytron wrote:

> The importer has been set up to set the creator, roster and
> moderators.
> Unfortunately, the current GS export from Karl2 does not export the
> members from the communities. There is a [Members] section of the
> .properties file, but it is blank. I will need to find out if that
> is a
> bug or if it was never implemented.
>
> --
> Migrate communities with correct roster
> https://bugs.launchpad.net/bugs/358681
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Porting KARL to a new architecture: New
>
> Bug description:
> Migrate communities, resulting in a correct listing of:
>
> - creator
>
> - moderators
>
> - members
>
> This likely means the first step is to get users into the system,
> and possibly profiles.

claytron (clayton-sixfeetup) wrote :

I talked to Tres briefly about this and he told me to just to look up the info in the pas db. There were a couple things I have questions about:

1) Does a group get automatically created for each community in Karl 2? Then each 'member' is added to that group?

2) According to the docs on carlos the members will be stored in postgres and use SQLAlchemy and repoze.who to do the rest. Is this still the case for karl3? From what I've seen the users are stored in the ZODB now.

Paul Everitt (paul-agendaless) wrote :

Tres will have to answer the first part. For the second, you are
correct: all user info and profile info is now in the ZODB.

--Paul

On Apr 17, 2009, at 9:32 AM, claytron wrote:

> I talked to Tres briefly about this and he told me to just to look up
> the info in the pas db. There were a couple things I have questions
> about:
>
> 1) Does a group get automatically created for each community in Karl
> 2?
> Then each 'member' is added to that group?
>
> 2) According to the docs on carlos the members will be stored in
> postgres and use SQLAlchemy and repoze.who to do the rest. Is this
> still the case for karl3? From what I've seen the users are stored in
> the ZODB now.
>
> --
> Migrate communities with correct roster
> https://bugs.launchpad.net/bugs/358681
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Porting KARL to a new architecture: New
>
> Bug description:
> Migrate communities, resulting in a correct listing of:
>
> - creator
>
> - moderators
>
> - members
>
> This likely means the first step is to get users into the system,
> and possibly profiles.

Paul Everitt (paul-agendaless) wrote :

Move to next week.

Changed in karl3:
milestone: m10 → m11
Tres Seaver (tseaver) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Paul Everitt wrote:
> Tres will have to answer the first part. For the second, you are
> correct: all user info and profile info is now in the ZODB.
>
> --Paul
>
> On Apr 17, 2009, at 9:32 AM, claytron wrote:
>
>> I talked to Tres briefly about this and he told me to just to look up
>> the info in the pas db. There were a couple things I have questions
>> about:
>>
>> 1) Does a group get automatically created for each community in Karl
>> 2?
>> Then each 'member' is added to that group?

Yes, see Products.kmi.content.community:Community.processForm.

Tres.
- --
===================================================================
Tres Seaver +1 540-429-0999 <email address hidden>
Palladion Software "Excellence by Design" http://palladion.com
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFJ6JAi+gerLs4ltQ4RAkSiAKDN30EeQJcePVWwTDXAXSm2Z8c9ogCfZB8R
JH/w9RJbXSC9vMVTgnJnHfk=
=MZfe
-----END PGP SIGNATURE-----

Paul Everitt (paul-agendaless) wrote :

For now, we'll reserve M11 Medium to mean: "things to get to feature completion"

Changed in karl3:
importance: Medium → Low
claytron (clayton-sixfeetup) wrote :

I added a export_profiles console script to the osi egg. This requires SQLAlchemy and pyscopg2 to access the pas db (which i haven't added to the requires). This exports most of the info we need to create profiles in the system.

In the importer script I wrote the load_profiles function to create the profiles in the system. I checked in a sample csv file along with an updated sample communities tarball. This task is probably 90% done. There are some UnicodeDecodeErrors and some edge cases that need to be cleaned up.

Moderators, creator and members can now be roughly imported into the system.

Paul Everitt (paul-agendaless) wrote :

Yeh, let's not add those to the requires. Let's consider the export
of those users to be something we do for OSI outside of what KARL3
supports, forever, for everybody.

In fact, I'd be happier adding that to the KARL2 requires if we really
had to.

--Paul

On Apr 24, 2009, at 1:29 AM, claytron wrote:

> I added a export_profiles console script to the osi egg. This
> requires
> SQLAlchemy and pyscopg2 to access the pas db (which i haven't added to
> the requires). This exports most of the info we need to create
> profiles
> in the system.
>
> In the importer script I wrote the load_profiles function to create
> the
> profiles in the system. I checked in a sample csv file along with an
> updated sample communities tarball. This task is probably 90% done.
> There are some UnicodeDecodeErrors and some edge cases that need to be
> cleaned up.
>
> Moderators, creator and members can now be roughly imported into the
> system.
>
> --
> Migrate communities with correct roster
> https://bugs.launchpad.net/bugs/358681
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Porting KARL to a new architecture: New
>
> Bug description:
> Migrate communities, resulting in a correct listing of:
>
> - creator
>
> - moderators
>
> - members
>
> This likely means the first step is to get users into the system,
> and possibly profiles.

Paul Everitt (paul-agendaless) wrote :

I'm going to mark this as Fix Committed. I believe Clayton thinks he has wrapped this up. If we find a bug, we can file a new issue.

Changed in karl3:
status: New → Fix Committed
Changed in karl3:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers