Test the policies for view-attachment

Bug #336503 reported by Paul Everitt on 2009-03-02
2
Affects Status Importance Assigned to Milestone
KARL3
Medium
Nat Katin-Borland

Bug Description

Changed in karl3:
importance: Undecided → Medium
milestone: none → m4

Looks good, can you explain this one a bit:

The attachment URLs in the show blog entry and show blog comment screens go directly to downloading the file. Thus, also provide a URL to get to the View File screen via a # that serves as a permalink hyperlink.

Its a great idea, I just need some clarification...

Hi Jonathan. Basically, we needed a way to get to the screens for
updating an attachment. In KARL2, attachments weren't stored in the
blog entry/comment. They were stored somewhat magically in the FILES
tool, with somewhat magical references from the blog entry/comment.

This meant, though, that the FILES tool provided a way to navigate to
the attachment if you needed to see the actions menu and operate on it.

We needed the same thing. But attachments aren't magically stored in
FILES in KARL3, they are inside the thing that it is attached to. I
thought to leverage the blog concept of the permalink.

--Paul

On Mar 6, 2009, at 5:26 PM, Jonathan Hooper wrote:

> Looks good, can you explain this one a bit:
>
> The attachment URLs in the show blog entry and show blog comment
> screens
> go directly to downloading the file. Thus, also provide a URL to get
> to
> the View File screen via a # that serves as a permalink hyperlink.
>
> Its a great idea, I just need some clarification...
>
> --
> Test the policies for view-attachment
> https://bugs.launchpad.net/bugs/336503
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Porting KARL to a new architecture: New
>
> Bug description:
> Confirm that the policies at http://carlos.agendaless.com/dko/policies/blog.html#view-attachment
> work.

Nat Katin-Borland (nborland) wrote :

I don't completely follow this, but I'm going to mark this confirmed b/c I assume it made sense to Jonathan.

Changed in karl3:
status: New → Confirmed
Changed in karl3:
assignee: nobody → nborland
Changed in karl3:
status: Confirmed → Fix Committed
Changed in karl3:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers