Test the policies for show-blog

Bug #336491 reported by Paul Everitt on 2009-03-02
2
Affects Status Importance Assigned to Milestone
KARL3
Medium
Nat Katin-Borland

Bug Description

Changed in karl3:
importance: Undecided → Medium
milestone: none → m4
Nat Katin-Borland (nborland) wrote :

Update from OSI:

-For blog description, remove html and grab the first xxx characters (how many would you suggest?). Number of characters should be a customizable setting.

Changed in karl3:
status: New → Confirmed

I ported the KARL2 policy as best I can. KARL2 doesn't have a
configuration knob.

--Paul

On Mar 4, 2009, at 5:01 PM, Nat Katin-Borland wrote:

> Update from OSI:
>
> -For blog description, remove html and grab the first xxx characters
> (how many would you suggest?). Number of characters should be a
> customizable setting.
>
> ** Changed in: karl3
> Status: New => Confirmed
>
> --
> Test the policies for show-blog
> https://bugs.launchpad.net/bugs/336491
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Porting KARL to a new architecture: Confirmed
>
> Bug description:
> Confirm that the UAT in http://carlos.agendaless.com/dko/policies/blog.html#show-blog
> works.

Paul Everitt (paul-agendaless) wrote :

As a record of what was done, after chatting with Jonathan about what
we did in KARL2:

"""
I just implemented the moral equivalent of this, with an XPath but not
XSLT:

1) Take the string of HTML and parse it with lxml.html. If it fails,
return None.

2) Grab all the text nodes with //text()

3) Skip empty strings in the list.

4) For each string, split on blank spaces and toss out any empty
strings.

5) Return the first 50 words. If over 50 words, add an ellipsis.

6) Store that on the instance, so we don't recompute it 20 times when
showing a blog or search results (since we aren't showing contextual
highlighting on search results.)
"""

On Mar 4, 2009, at 5:01 PM, Nat Katin-Borland wrote:

> Update from OSI:
>
> -For blog description, remove html and grab the first xxx characters
> (how many would you suggest?). Number of characters should be a
> customizable setting.
>
> ** Changed in: karl3
> Status: New => Confirmed
>
> --
> Test the policies for show-blog
> https://bugs.launchpad.net/bugs/336491
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Porting KARL to a new architecture: Confirmed
>
> Bug description:
> Confirm that the UAT in http://carlos.agendaless.com/dko/policies/blog.html#show-blog
> works.

Paul Everitt (paul-agendaless) wrote :

Tested this on IE last night on carlos. Much of the functionality is there, but long list of small bugs on the various blog/email screens. I'll get with Nat this morning to schedule a walkthrough.

Changed in karl3:
assignee: nobody → nborland
Nat Katin-Borland (nborland) wrote :

I'm not going to submit a bug on how email-in comments are getting cropped since you saw this when we were doing our update on the phone this morning. Let me know if you want me to submit a bug for this. Other than that, I'm going commit.

Changed in karl3:
status: Confirmed → Fix Committed
assignee: nborland → paul-agendaless
Paul Everitt (paul-agendaless) wrote :

Housecleaning, no action needed (already Fix Committed).

Changed in karl3:
assignee: paul-agendaless → nborland
Changed in karl3:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers