Test policies for show-login

Bug #333346 reported by Paul Everitt on 2009-02-23
2
Affects Status Importance Assigned to Milestone
KARL3
Medium
Nat Katin-Borland

Bug Description

Changed in karl3:
importance: Undecided → Medium
milestone: none → m3
description: updated
Nat Katin-Borland (nborland) wrote :

Updates from OSI:

Show Login

-Change Bad to Incorrect in the “Bad username or password” message

-If a user has clicked Remember Me, they will not be required to login again until they click logout.

-How long does the Remember Me cookie last?

-Forgot password link needs to be able to point to an external url (for example, the GSA’s forgot password page as currently used in KARL2)

Changed in karl3:
status: New → Confirmed

(Updating from previous answers.)

I'll change the wording in the prompt.

The Remember Me lasts until 2038 (when we implement it, as noted in
another bug, we haven't implemented that yet.)

KARL2 invitations can't be shared as they are keyed to email address.
Thus, we don't do expiration in KARL2.

--Paul

On Mar 5, 2009, at 2:32 PM, Nat Katin-Borland wrote:

> Updates from OSI:
>
> Show Login
>
> -Change Bad to Incorrect in the “Bad username or password” message
>
> -If a user has clicked Remember Me, they will not be required to login
> again until they click logout.
>
> -How long does the Remember Me cookie last?
>
> -Forgot password link needs to be able to point to an external url
> (for
> example, the GSA’s forgot password page as currently used in KARL2)
>
>
> ** Changed in: karl3
> Status: New => Confirmed
>
> --
> Test policies for show-login
> https://bugs.launchpad.net/bugs/333346
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Porting KARL to a new architecture: Confirmed
>
> Bug description:
> Confirm the policies at http://carlos.agendaless.com/dko/policies/login.html#show-login

Paul Everitt (paul-agendaless) wrote :

I just confirmed this screen using IE on the updated carlos site.

Changed in karl3:
assignee: nobody → nborland
Changed in karl3:
status: Confirmed → Fix Committed
Will Seaver (will-seaver) wrote :

# The link “I forgot my password” should go to the password recovery screen.

http://kdiab.sixfeetup.com/requestreset.html

this feature does not appear to be implemented yet

Will Seaver (will-seaver) wrote :

# Otherwise, logging in should send you to your “default” screen. For “staff”, this is your office home page. Otherwise, it is the communities screen.

Upon login, staff users are directed to the communities page

Will Seaver (will-seaver) wrote :

checked in a test that conforms to this policy

Paul Everitt (paul-agendaless) wrote :

Right, we aren't assigning a home office to the fake users. We could
consider doing so, but I think we'll ignore it for now.

--Paul

On Apr 30, 2009, at 1:51 PM, Will Seaver wrote:

> # Otherwise, logging in should send you to your “default” screen. For
> “staff”, this is your office home page. Otherwise, it is the
> communities
> screen.
>
> Upon login, staff users are directed to the communities page
>
> --
> Test policies for show-login
> https://bugs.launchpad.net/bugs/333346
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Porting KARL to a new architecture: Fix Committed
>
> Bug description:
> Confirm the policies at http://carlos.agendaless.com/dko/policies/login.html#show-login

Paul Everitt (paul-agendaless) wrote :

Correct, I'm writing that up as we speak.

--Paul

On Apr 30, 2009, at 1:48 PM, Will Seaver wrote:

> # The link “I forgot my password” should go to the password recovery
> screen.
>
> http://kdiab.sixfeetup.com/requestreset.html
>
> this feature does not appear to be implemented yet
>
> --
> Test policies for show-login
> https://bugs.launchpad.net/bugs/333346
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Porting KARL to a new architecture: Fix Committed
>
> Bug description:
> Confirm the policies at http://carlos.agendaless.com/dko/policies/login.html#show-login

Changed in karl3:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers