NotFound exceptions should be ignored by the error monitor

Bug #1018909 reported by Paul Everitt on 2012-06-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KARL3
Medium
Chris Rossi

Bug Description

NotFound exceptions percolate up into the error monitor and raise an alarm. They shouldn't.

This was actually caused by some misbehaving Chatter code, which was causing all errors to be turned into General Errors. You'll find that on production, currently, going to any URL that should be a NotFound will generate an General Error and trip the alarm. This is now fixed on the branch, fix_notfound.

Additionally, it became apparent that it might be useful to track not found errors as long as they don't trip the alarm, so I also added some code to log NotFound errors to the redislog using the NOTFOUND category, which does not trip the alarm.

Changed in karl3:
status: New → Fix Committed

Chris, is this something that needs to be tested on a karldev branch? I doubt Jim or I could add much value on this.

--Paul

On Jul 6, 2012, at 10:27 PM, Chris Rossi wrote:

> This was actually caused by some misbehaving Chatter code, which was
> causing all errors to be turned into General Errors. You'll find that
> on production, currently, going to any URL that should be a NotFound
> will generate an General Error and trip the alarm. This is now fixed on
> the branch, fix_notfound.
>
> Additionally, it became apparent that it might be useful to track not
> found errors as long as they don't trip the alarm, so I also added some
> code to log NotFound errors to the redislog using the NOTFOUND category,
> which does not trip the alarm.
>
>
> ** Changed in: karl3
> Status: New => Fix Committed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1018909
>
> Title:
> NotFound exceptions should be ignored by the error monitor
>
> Status in KARL3:
> Fix Committed
>
> Bug description:
> NotFound exceptions percolate up into the error monitor and raise an
> alarm. They shouldn't.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/karl3/+bug/1018909/+subscriptions

JimPGlenn (jpglenn09) on 2012-07-11
tags: added: r3.90

On Sat, Jul 7, 2012 at 3:47 AM, Paul Everitt <email address hidden> wrote:
> Chris, is this something that needs to be tested on a karldev branch? I doubt Jim or I could add much value on this.
>
To test, go to any URL that doesn't exist. You should see a Not Found
instead of a General Error. It should also now show up in /log.html
in the notfound category.

Nat Katin-Borland (nborland) wrote :

Looks good as far as I can tell, but Jim should confirm as well.

JimPGlenn (jpglenn09) wrote :

fixed

Changed in karl3:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers