ux2 edit calendar categories broken

Bug #1017944 reported by Balazs Ree on 2012-06-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KARL3
Medium
Carlos de la Guardia

Bug Description

On the calendar setup page, there is a possibility to edit a category or a layer, by clicking on the Edit link in the table row.

However this silently does not do anything. Probably a simple selector / js bind problem, and now the click event is not bound on these links.

Paul Everitt (paul-agendaless) wrote :

Balazs is correct. This works right in UX1...it makes a hidden <input> appear. It is broken though on UX2...looks like we don't have a JS handler for that <a> click.

Changed in karl3:
assignee: nobody → blaflamme (blaise-laflamme)
importance: Undecided → Medium
milestone: none → m109
JimPGlenn (jpglenn09) on 2012-06-26
tags: added: r3.89 tested
Changed in karl3:
status: New → Fix Committed
JimPGlenn (jpglenn09) on 2012-06-26
Changed in karl3:
status: Fix Committed → Fix Released
blaflamme (blaise-laflamme) wrote :

can't see what I have to do, and it's fix released?

Changed in karl3:
assignee: blaflamme (blaise-laflamme) → JimPGlenn (jpglenn09)
Paul Everitt (paul-agendaless) wrote :

Blaise is correct, this was marked Fixed Released but wasn't worked on.

Blaise, to recreate:

1) Go to a calendar in a community that you moderate.

2) Click "setup"

3) Click "edit"

Here is a screencast: http://www.screencast.com/t/oRDON7Tx4sl

In ux1, there is a JS handler on the "edit" which causes an <input> to appear.

Changed in karl3:
assignee: JimPGlenn (jpglenn09) → blaflamme (blaise-laflamme)
milestone: m109 → m110
status: Fix Released → Confirmed
Paul Everitt (paul-agendaless) wrote :

Carlos needs some stuff on his plate.

Changed in karl3:
assignee: blaflamme (blaise-laflamme) → Carlos de la Guardia (cguardia)
Changed in karl3:
status: Confirmed → Fix Committed

Looks good (on FF) on ux2 karldev:

https://karldev.gocept.com/ux2/osf/communities/test/calendar/categories.html

--Paul

On Jul 4, 2012, at 1:51 AM, Carlos de la Guardia wrote:

> ** Changed in: karl3
> Status: Confirmed => Fix Committed
>
> --
> You received this bug notification because you are subscribed to KARL3.
> https://bugs.launchpad.net/bugs/1017944
>
> Title:
> ux2 edit calendar categories broken
>
> Status in KARL3:
> Fix Committed
>
> Bug description:
> On the calendar setup page, there is a possibility to edit a category
> or a layer, by clicking on the Edit link in the table row.
>
> However this silently does not do anything. Probably a simple selector
> / js bind problem, and now the click event is not bound on these
> links.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/karl3/+bug/1017944/+subscriptions

JimPGlenn (jpglenn09) on 2012-07-06
tags: removed: r3.89 tested
JimPGlenn (jpglenn09) wrote :

tested on IE8 and Ie9 also looks good

tags: added: tested ux2
JimPGlenn (jpglenn09) on 2012-08-30
tags: added: r3.91
JimPGlenn (jpglenn09) wrote :

fixed

Changed in karl3:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers