Clicking on User's Name in Chatter Direct Messages Throws Error

Bug #1009662 reported by Nat Katin-Borland on 2012-06-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KARL3
Low
Carlos de la Guardia

Bug Description

Clicking on the linked user's name on the List of conversations on the Direct Messages screen throws a "Not Found" screen. I assume that this is the case because it just hasn't been implemented yet, but I thought I would send in a ticket anyway.

Changed in karl3:
assignee: nobody → Carlos de la Guardia (cguardia)
importance: Undecided → Medium
milestone: none → m107
tags: added: chatter ux2
Carlos de la Guardia (cguardia) wrote :

It works correctly for me.

Changed in karl3:
status: New → Invalid
Paul Everitt (paul-agendaless) wrote :

I agree with Carlos that this works when you are in the full-screen of direct messages. I tried on IE8 as well as FF.

Where it doesn't work is in the pushdown. I think this is by design...we don't want clickable links on people's names in the pushdown. However, we have it as an <a> with a pointer when you mouseover. Which makes it misleading.

Changed in karl3:
status: Invalid → Confirmed
Changed in karl3:
importance: Medium → Low
Carlos de la Guardia (cguardia) wrote :

Turns out there is a real issue here with chatter user names. We use the NotFound view for finding out if there link is to a user, which works fine in *debug* mode. In production, the debug flag is not set and then a different NotFound view overrides the chatter finder, to show the Karl error page. We'll need to fix this on the next iteration.

Changed in karl3:
status: Confirmed → In Progress
JimPGlenn (jpglenn09) on 2012-06-18
Changed in karl3:
milestone: m107 → m108
Changed in karl3:
status: In Progress → Fix Committed

Works.

On Jun 24, 2012, at 9:08 PM, Carlos de la Guardia wrote:

> ** Changed in: karl3
> Status: In Progress => Fix Committed
>
> --
> You received this bug notification because you are subscribed to KARL3.
> https://bugs.launchpad.net/bugs/1009662
>
> Title:
> Clicking on User's Name in Chatter Direct Messages Throws Error
>
> Status in KARL3:
> Fix Committed
>
> Bug description:
> Clicking on the linked user's name on the List of conversations on the
> Direct Messages screen throws a "Not Found" screen. I assume that
> this is the case because it just hasn't been implemented yet, but I
> thought I would send in a ticket anyway.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/karl3/+bug/1009662/+subscriptions

JimPGlenn (jpglenn09) on 2012-06-25
tags: added: r3.89 tested
JimPGlenn (jpglenn09) on 2012-06-26
Changed in karl3:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers