Implement all_forums.html for UX2

Bug #1007476 reported by Paul Everitt on 2012-06-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KARL3
Medium
Chris Rossi
Changed in karl3:
assignee: nobody → Chris Rossi (chris-archimedeanco)
Changed in karl3:
milestone: m105 → m106

Done. Handing over to Blaise for additional styling tweaks. This template is actually part of the osi customization package and not part of standard Karl. In order to see/work on this you'll need to do:

$ bin/develop co osi
$ bin/buildout -No
$ bin/karlserve settings set pg package osi

The new template is in src/osi/osi/ux2/templates/all_forums.pt

Changed in karl3:
status: New → In Progress
assignee: Chris Rossi (chris-archimedeanco) → blaflamme (blaise-laflamme)
blaflamme (blaise-laflamme) wrote :

fixed makrup + css

Changed in karl3:
assignee: blaflamme (blaise-laflamme) → JimPGlenn (jpglenn09)
status: In Progress → Fix Committed
JimPGlenn (jpglenn09) wrote :

got a f404 on ux2/dev...I am not sure what branch to test this on?

https://karldev.gocept.com/ux2/osf/offices/forums/all_forums.html

--Paul

On Jun 11, 2012, at 8:07 AM, JimPGlenn wrote:

> got a f404 on ux2/dev...I am not sure what branch to test this on?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1007476
>
> Title:
> Implement all_forums.html for UX2
>
> Status in KARL3:
> Fix Committed
>
> Bug description:
> At: https://karl.soros.org/offices/forums/all_forums.html
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/karl3/+bug/1007476/+subscriptions

JimPGlenn (jpglenn09) wrote :

looks good

tags: added: tested
JimPGlenn (jpglenn09) wrote :

forums appear to workk but offices/forums/all_forums.html gives me a F404 on staging

Changed in karl3:
status: Fix Committed → In Progress
assignee: JimPGlenn (jpglenn09) → Chris Rossi (chris-archimedeanco)
Paul Everitt (paul-agendaless) wrote :

Carlos has been doing the forums stuff.

Changed in karl3:
milestone: m106 → m108
assignee: Chris Rossi (chris-archimedeanco) → Carlos de la Guardia (cguardia)
JimPGlenn (jpglenn09) on 2012-06-21
tags: removed: tested
Nat Katin-Borland (nborland) wrote :

I'm getting a Content Not Found page when I try to test this on Staging.

Carlos de la Guardia (cguardia) wrote :

This works here: https://karldev.gocept.com/ux2/osf/offices/forums/all_forums.html

I'm unsure what to do about this ticket.

Changed in karl3:
status: In Progress → Fix Committed
Paul Everitt (paul-agendaless) wrote :

This URL works in production:

  https://karl.soros.org/offices/forums/all_forums.html

...but this gives a 404 on staging:

  https://karlstaging.gocept.com/offices/forums/all_forums.html

On Jun 23, 2012, at 2:08 PM, Carlos de la Guardia wrote:

> This works here:
> https://karldev.gocept.com/ux2/osf/offices/forums/all_forums.html
>
> I'm unsure what to do about this ticket.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1007476
>
> Title:
> Implement all_forums.html for UX2
>
> Status in KARL3:
> In Progress
>
> Bug description:
> At: https://karl.soros.org/offices/forums/all_forums.html
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/karl3/+bug/1007476/+subscriptions

This works in my sandbox with the osi package set. Are we sure karlstaging has that?

Paul Everitt (paul-agendaless) wrote :

Handing to Chris for investigation about whether karlstaging is setup right.

Changed in karl3:
status: Fix Committed → In Progress
assignee: Carlos de la Guardia (cguardia) → Chris Rossi (chris-archimedeanco)
milestone: m108 → m109
Paul Everitt (paul-agendaless) wrote :

After the production update, we still have this. Here's the sequence to get to it, in production:

1) Go to the NYC office homepage: https://karl.soros.org/offices/nyc/

2) In right column, click "MORE New York News"

3) Click "Back to Forums"

3) Click "All Forums"

That screen is at:

https://karl.soros.org/offices/nyc/forums/all_forums.html

...and wrongly has the community style.

Changed in karl3:
assignee: Chris Rossi (chris-archimedeanco) → Carlos de la Guardia (cguardia)
Changed in karl3:
status: In Progress → Fix Committed
JimPGlenn (jpglenn09) wrote :

looks good

tags: added: tested
Nat Katin-Borland (nborland) wrote :

I'm getting a General Error when I try to visit the All Forums page (https://karlstaging.gocept.com/offices/forums/all_forums.html).

Traceback:

<!--
       Traceback (most recent call last):
  File "/srv/karlstaging/staging/3/eggs/pyramid-1.2.1-py2.6.egg/pyramid/tweens.py", line 17, in excview_tween
    response = handler(request)
  File "/srv/karlstaging/staging/3/eggs/pyramid-1.2.1-py2.6.egg/pyramid/router.py", line 151, in handle_request
    raise HTTPNotFound(msg)
HTTPNotFound: /offices/forums/all_forums.html

     -->

    </div>

  </div>
        </section>
    </div>

    <!-- extras from layout manager -->
      <link rel="stylesheet" href="https://karlstaging.gocept.com/static/r1344006699/tinymce/min/karl-ux2-tinymce.min.css" />
  <link rel="stylesheet" href="https://karlstaging.gocept.com/static/r1344006699/slick/2.0.1/slick.grid.css" />
  <link rel="stylesheet" href="https://karlstaging.gocept.com/static/r1344006699/ux2/js/jquery-ui-1.9m5-smoothness.min.css" />
  <link rel="stylesheet" href="https://karlstaging.gocept.com/static/r1344006699/ux2/main.css" />
      <script src="https://karlstaging.gocept.com/static/r1344006699/ux2/min/karl-ux2-core.min.js" defer></script>
  <script src="https://karlstaging.gocept.com/static/r1344006699/tinymce/min/karl-ux2-tinymce.min.js" defer></script>
  <script src="https://karlstaging.gocept.com/static/r1344006699/ux2/min/karl-ux2-legacy.min.js" defer></script>
  <script src="https://karlstaging.gocept.com/static/r1344006699/ux2/plugins/popper-livesearch/popper.livesearch.js" defer></script>
  <script src="https://karlstaging.gocept.com/static/r1344006699/ux2/plugins/popper-tagbox/popper.tagbox.js" defer></script>
  <script src="https://karlstaging.gocept.com/static/r1344006699/ux2/plugins/popper-pushdown/popper.pushdown.js" defer></script>
  <script src="https://karlstaging.gocept.com/static/r1344006699/ux2/js/pushdown.js" defer></script>
  <script src="https://karlstaging.gocept.com/static/r1344006699/ux2/js/popper.js" defer></script>
  <script src="https://karlstaging.gocept.com/static/r1344006699/ux2/plugins/karl-calendar/karl.calendar.js" defer></script>
  <script src="https://karlstaging.gocept.com/static/r1344006699/ux2/plugins/karl-datetimepicker/karl.datetimepicker.js" defer></script>
  <script src="https://karlstaging.gocept.com/static/r1344006699/ux2/karl-ux2.js" defer></script>

    <!-- ready hold is released from layout-prologue.js -->
    <script type="text/javascript" src="https://karlstaging.gocept.com/static/r1344006699/ux2/js/layout-prologue.js" defer></script>

    </body>
</html>

Paul Everitt (paul-agendaless) wrote :

Confirmed, I will re-open.

Changed in karl3:
milestone: m109 → m115
status: Fix Committed → In Progress
JimPGlenn (jpglenn09) on 2012-08-15
tags: removed: tested
Nat Katin-Borland (nborland) wrote :

Still throwing a general error

The only thing my fix did was in response to comment #13, removing the community style. That still works. Both my Sandbox and karldev show the page just fine, as does production. I'm not sure why the URL for staging fails, but isn't that a separate problem? Maybe we need a new ticket for that?

Paul Everitt (paul-agendaless) wrote :

I am sending Carlos a screencast URL in email. I can't post it here because it shows OSF content.

Forgive my insistence, but as far as I can determine without staging access, the problem here is that the osi package is not set on https://karlstaging.gocept.com/. Both my development sandbox (with osi package set) and production correctly show the "all forums" button and link to the correct page, as shown on the screencast. Both show ux2 UI when activated. On staging we have a not found error, which would happen if the view configuration was not activated.

As indirect evidence for my theory, not just all_forums.html does not work on staging, but all the views defined on the osi package are not found. For example, the '/metrics' admin view gives not found, as does the '/people/layouts/<tab>' alias.

Paul Everitt (paul-agendaless) wrote :

Assigning to Chris to investigate Carlos's last comment. I know we had some similar issues earlier in the week on staging.

Changed in karl3:
assignee: Carlos de la Guardia (cguardia) → Chris Rossi (chris-archimedeanco)
milestone: m115 → m116

I've fixed the problem with staging. The osi customization package is back in use there.

Changed in karl3:
status: In Progress → Fix Committed
JimPGlenn (jpglenn09) wrote :

I tested this on dev/master and it looks good and worked fine. On staging I did not get an all_forums button. When I put the url in I got a F404 on staging.

Paul Everitt (paul-agendaless) wrote :

Carlos, can you and Chris get together and sort this out? Jim and I aren't adding much value.

--Paul

On Aug 20, 2012, at 12:57 PM, JimPGlenn wrote:

> I tested this on dev/master and it looks good and worked fine. On
> staging I did not get an all_forums button. When I put the url in I got
> a F404 on staging.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1007476
>
> Title:
> Implement all_forums.html for UX2
>
> Status in KARL3:
> Fix Committed
>
> Bug description:
> At: https://karl.soros.org/offices/forums/all_forums.html
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/karl3/+bug/1007476/+subscriptions

Paul Everitt (paul-agendaless) wrote :

FWIW, Jim is correct. This URL:

  https://karlstaging.gocept.com/offices/nyc/forums/

...does not show "All Forums" in the action menu. I did this logged in as KarlStaff/KarlAdmin.

At:

  https://karl.soros.org/offices/nyc/forums/

...we do have All Forums in the action menu.

--Paul

On Aug 20, 2012, at 12:57 PM, JimPGlenn wrote:

> I tested this on dev/master and it looks good and worked fine. On
> staging I did not get an all_forums button. When I put the url in I got
> a F404 on staging.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1007476
>
> Title:
> Implement all_forums.html for UX2
>
> Status in KARL3:
> Fix Committed
>
> Bug description:
> At: https://karl.soros.org/offices/forums/all_forums.html
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/karl3/+bug/1007476/+subscriptions

Changed in karl3:
status: Fix Committed → In Progress

Actually fixed the package thing this time. Sorry about that.

Changed in karl3:
status: In Progress → Fix Committed
JimPGlenn (jpglenn09) wrote :

I tested this on staging and got the all_forums button and when I clicked I got all the nyc forums. I believe this is correct and
it looked good.

tags: added: tested
JimPGlenn (jpglenn09) on 2012-08-30
tags: added: r3.91
JimPGlenn (jpglenn09) wrote :

fixed

Changed in karl3:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers