Tag Widget Doesn't Work on Add Content Forms

Bug #1000381 reported by Nat Katin-Borland on 2012-05-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KARL3
Medium
JimPGlenn

Bug Description

The tag widget doesn't work on the add content form. For example, on the add blog post form nothing happens when you type something into the tag box. No live search is triggered and no tag is passed over when you click submit.

Paul Everitt (paul-agendaless) wrote :

I believe this has been previously reported, but just in case, assigning to Balazs.

Changed in karl3:
assignee: nobody → Balazs Ree (ree)
importance: Undecided → Medium
milestone: none → m105
tags: added: tags ux2
Changed in karl3:
milestone: m105 → m106
JimPGlenn (jpglenn09) on 2012-06-11
Changed in karl3:
milestone: m106 → m107
Balazs Ree (ree) on 2012-06-13
Changed in karl3:
status: New → Confirmed
Balazs Ree (ree) on 2012-06-14
Changed in karl3:
status: Confirmed → Fix Committed
JimPGlenn (jpglenn09) wrote :

The tags under "tag cloud" are for that community even though it says all tags across Karl. There is a tag called Sample in one community that does not show up when you come from another community and request the Tag Cloud. Also I am not sure what the box is for if not to search and it does not appear to work. Lastly there is no current way to add a tag to an item other than adding it in such as a blog add. When you add a comment it does not allow you to add a tag.

Changed in karl3:
status: Fix Committed → In Progress
JimPGlenn (jpglenn09) wrote :

see screenshot

JimPGlenn (jpglenn09) on 2012-06-18
Changed in karl3:
milestone: m107 → m108
Balazs Ree (ree) wrote :

    1): "The tags under "tag cloud" are for that community even though it says all tags across Karl. There is a tag called Sample in
    one community that does not show up when you come from another community and request the Tag Cloud."

Jim, could you please help me giving me a karldev url that you test, and two screenshots with ux1 and ux2 that shows the difference?

    2): "Also I am not sure what the box is for if not to search and it does not appear to work. "

I think I fixed this.

    3): Lastly there is no current way to add a tag to an item other than adding it in such as a blog add. When you add a comment it
          does

I think I fixed this too.

Summarizing, 2) and 3) believed to be fixed, and I am waiting for some help input with 1).
    not allow you to add a tag.

I think I fixed this too.

Changed in karl3:
status: In Progress → Incomplete
Paul Everitt (paul-agendaless) wrote :

I can't recreate the problem about the global tag cloud. Works for me.

Changed in karl3:
assignee: Balazs Ree (ree) → JimPGlenn (jpglenn09)
status: Incomplete → Fix Committed
JimPGlenn (jpglenn09) wrote :

This looks good

tags: added: tested
JimPGlenn (jpglenn09) on 2012-06-20
tags: added: r3.89
JimPGlenn (jpglenn09) wrote :

IE8 IE9 and FF still looks good

JimPGlenn (jpglenn09) on 2012-06-26
Changed in karl3:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers