After crash, system thinks wifi is available but it's not

Bug #418327 reported by Scott Kitterman
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KDE Airplane Mode
Fix Released
Undecided
Rich Johnson

Bug Description

After a crash, knetworkmanager started trying to connect as it thought wifi was available, but it wasn't. The current design of wifi staying off is good, but it'd be nice if knetworkmanager knew it wasn't available and didn't start trying in vain to connect.

Related branches

Revision history for this message
Rich Johnson (nixternal) wrote :

Yikes, I wonder if this is something I can fix with kairmode or if it should be done with knetworkmangler. I will look into this.

Changed in kairmode:
assignee: nobody → Richard Johnson (nixternal)
status: New → Incomplete
Revision history for this message
Rich Johnson (nixternal) wrote :

I am not able to reproduce this Scott. If I enable airplane mode, wifi shuts off and network mangler doesn't try to do anything.

Now, this could have been a problem when the app crashed, it really didn't shut off the wifi. In other words, "Tx-Power=0 db" and not "Tx-Power=off". If Tx-Power == 0db, what was happening is that the app actually had marked the power status as None instead of off or on. I think if this was an issue, I may have cleared it up with recent updates to the code. I will mark this "Fix Committed" right now. If this continues after the new package is uploaded, then I say reopen this bad boy. Thanks!

Changed in kairmode:
status: Incomplete → Fix Committed
Rich Johnson (nixternal)
Changed in kairmode:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers