Airplane mode crashed

Bug #418324 reported by Scott Kitterman
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KDE Airplane Mode
Fix Released
Undecided
Rich Johnson

Bug Description

The first time I tried to set airplane mode (after running it from command line) I got a segfault (with no details). After restart it worked fine, so unable to replicate so far.

Related branches

Revision history for this message
Rich Johnson (nixternal) wrote :

Ya, this is an issue with the KDialog and its return of .Yes or .No.

Changed in kairmode:
assignee: nobody → Richard Johnson (nixternal)
status: New → Confirmed
Revision history for this message
Rich Johnson (nixternal) wrote :
Download full text (8.6 KiB)

=== modified file 'kairmode.py'
--- kairmode.py 2009-08-25 04:53:27 +0000
+++ kairmode.py 2009-08-25 19:42:35 +0000
@@ -33,9 +33,7 @@
 class App(QObject):
     def __init__(self):
         QObject.__init__(self)
- self.init()

- def init(self):
         # Wireless devices
         self.wifi_device = self.getWiFiDeviceInfo()
         self.wifi_power = self.getWiFiDevicePowerStatus()
@@ -52,7 +50,7 @@ ...

Read more...

Changed in kairmode:
status: Confirmed → Fix Committed
Rich Johnson (nixternal)
Changed in kairmode:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers