DVB-T - "Could not open media source"

Bug #453916 reported by juhge
This bug affects 5 people
Affects Status Importance Assigned to Milestone
kaffeine (Ubuntu)
Nominated for Karmic by Philipp Kern

Bug Description

After changin to Ubuntu 9.10 and kaffeine 1.0 the program only shows an error "Could not open media source" by clicking on a channel. I'm able to search for channels and it shows me the diffrent programs but I can't open the streams.

Using kaffeine 0.8.7 I was able to use my dvb-t stick.

lsusb: Bus 001 Device 003: ID 0ccd:005a TerraTec Electronic GmbH

dmesg: [ 14.078174] dvb-usb: Terratec Cinergy DT XS Diversity successfully initialized and connected.
             [ 14.078370] usbcore: registered new interface driver dvb_usb_dib0700

Starting kaffeine it shows me an error about the phonon system

"The audio playback device HDA nVidia (ALC888) doesn't work. Falling back to default"

but I'm able to play audio files with rhythmbox without problems or errors

In a terminal this errors are shown:
Object::connect: No such signal Phonon::Gstreamer::MediaObject::availableSubtitlesChanged()
Object::connect: No such signal Phonon::Gstreamer::MediaObject::availableAudioChannelsChanged()
Object::connect: No such signal Phonon::Gstreamer::MediaObject::titleChanged(int)
Object::connect: No such signal Phonon::Gstreamer::MediaObject::availableTitlesChanged(int)
Object::connect: No such signal Phonon::Gstreamer::MediaObject::chapterChanged(int)
Object::connect: No such signal Phonon::Gstreamer::MediaObject::availableChaptersChanged(int)
Object::connect: No such signal Phonon::Gstreamer::MediaObject::angleChanged(int)
Object::connect: No such signal Phonon::Gstreamer::MediaObject::availableAnglesChanged(int)

I can't find any hint solving this strange problem.

Thank you for your help.

Revision history for this message
Fred61 (friedhelm-hinrichs) wrote :

I have the same problem after upgrading to ubuntu 9.10, final version. lspci correctly lists the PCI-card:

01:05.0 Network controller: Techsan Electronics Co Ltd B2C2 FlexCopII DVB chip / Technisat SkyStar2 DVB card (rev 02)

dmesg also shows the card:

[ 11.530138] b2c2-flexcop: found 'ST STV0299 DVB-S' .
[ 11.530143] DVB: registering adapter 0 frontend 0 (ST STV0299 DVB-S)...
[ 11.530202] b2c2-flexcop: initialization of 'Sky2PC/SkyStar 2 DVB-S rev 2.6' at the 'PCI' bus controlled by a 'FlexCopIIb' complete

A frequency scan was done successfully, but I'm not able to switch to any channel. When starting kaffeine I get the same error message. So this looks like not being a USB or OCI problem, but a general problem between kaffeine and phonon.

Any help is welcome!

Revision history for this message
Fred61 (friedhelm-hinrichs) wrote :

Problem fixed!

Adding package phonon-backend-xine removed the above error messages but lead to a new error:

demux_wavpack: (open_wv_file:127) open_wv_file: non-seekable inputs aren't supported yet.

Then I added
 - libxine1-plugins
 - libxine1-all-plugins

Now kaffeine is able to select and display the DVB channels!

I hope this will help.

Revision history for this message
Rovano (rovano) wrote :

If is very low signal, is same problem. But else ok.

Revision history for this message
oustedaisse (oustedaisse-deactivatedaccount) wrote :

Same issue, fixed by installing phonon-backend-xine (thanks Fred61)
I think it's could be a great thing if kaffeine depend on phonon-backend-xine !!

Revision history for this message
Julien K (julien-k) wrote :

Same issue, same solution! Thank you very much Fred61!

Revision history for this message
Craig Chambers (craigchambers) wrote :

Same issue with Hauppauge WinTV-Nova HD-S2.
The app now began to crash with a seg fault.
I had to finally run the app with sudo, and now it works properly.

Thanks for the advice folks.

Revision history for this message
Philipp Kern (pkern) wrote :

DVB playback is broken due to the undeclared dependency on phonon-backend-xine. Could we get a SRU for this? This is a regression over Jaunty with Ubuntu, it is not pulled in on upgrade by anything else when starting off a Gnome desktop install. It is pulled in by kubuntu-desktop, though.

Changed in kaffeine (Ubuntu):
status: New → Confirmed
Revision history for this message
Patrick McEvoy (patrickmcevoy) wrote :

Also required phonon-backend-xine, and to run with sudo.

Revision history for this message
BobFed (jonathan-harbour-design) wrote :

I had this problem when I upgraded from Jaunty.
I have found the previous packaged version of kaffeine 0.8.6 though which works:
I am using a Hauppauge Nova-TD 52XXX I you are wondering.

Revision history for this message
Peter Wagner (o-petris) wrote :

same error (media not found), same solution (thanks to Fred61!!), phonon-backend-xine is enough

Revision history for this message
Serge (belloveso) wrote :

Great solution!! Thanks Fred61

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.