No XChat in Dapper

Bug #38694 reported by Tony Yarusso
28
Affects Status Importance Assigned to Milestone
Juniper Openstack
Status tracked in Trunk
R4.0
Fix Committed
Medium
Unassigned
R4.1
Fix Committed
Medium
Unassigned
Trunk
Fix Committed
Medium
Unassigned
ubuntu-meta (Ubuntu)
Medium
Unassigned

Bug Description

Apparently someone made the decision to remove XChat from the default installation for Dapper. This is important because it is the means new users use to reach the various IRC channels on Freenode and all the support those have to offer. I understand that Gaim is still included and supports IRC, but this has a few problems as an alternative. First, new users are not going to thing that Gaim Internet Messenger in their Applications menu has anything to do with getting support. Second, setting up, connecting to, and using IRC isn't entirely intuitive. Third, many people simply don't like Gaim's IRC UI. Fourth, it does not have the built-in setting like XChat had to automatically join #ubuntu when first started. In short, a brand new user is significantly less likely to manage to find the support of the IRC channels on their first boot of Ubuntu without XChat included and not knowing the ropes pretty well already. The IRC channels are an absolutely vital way of helping new users, and must be very easily accessible. Inclusion of XChat is a big step towards that. (Further UI setup for first boot are an issue as well, but that's a separate issue.)

Revision history for this message
Eric Feliksik (milouny) wrote :

Thanks for your bug.
According to https://wiki.ubuntu.com/UbuntuLiveChatSupport , this is intended, and a Help-wizard will make it easy to get on #ubuntu with gaim.

Of course, for further stuff (channels, servers) you might still want to use xchat, but if you really want to use IRC you'll probably find out how to instal xchat.

Note that I don't know if this will really make Dapper, so I'm keeping this bug open.

Revision history for this message
Matthew East (mdke) wrote :

Thanks for your report. The removal of xchat from Ubuntu was an extremely deliberate decision, and the advantages and disadvantages were debated at length by the development team. I feel sure that the points you mention were included in that debate.

I'm afraid this isn't a bug, but rather a feature.

Changed in xchat:
status: Unconfirmed → Rejected
Revision history for this message
Brian Burger (bburger) wrote :

I'm re-opening this, because I'd really like to here from some of the developers or packagers about leaving XChat or XChat-Gnome out of Dapper.

I've just spent a couple of hours using Gaim in Dapper Beta (LiveCD) and for basic IRC it has a fairly bad UI, and seems worse than XChat-Gnome would be.

Having all the options & menus spread over several windows (three, usually) isn't very useful; it's difficult to find a basic channel listing, and while I'm not a great fan of XChat-Gnome, isn't an app that's actually designed for IRC better than one that tries to do everything?

Changed in ubuntu-meta:
status: Rejected → Needs Info
Revision history for this message
Brian Burger (bburger) wrote :

hear, not here... must proofread bug-reports better!

Revision history for this message
Peter Garrett (peter-garrett) wrote :

Matthew East says: "I'm afraid this isn't a bug, but rather a feature."

I'm intrigued by this. How exactly is it a feature to expect people to use an app that isn't really purpose-designed for IRC ?

There are times when a new user is told to use certain commands in their IRC client that simply don't work in Gaim.
This only makes helping them more difficult, really.

Revision history for this message
Matthew East (mdke) wrote : Re: [Bug 38694] Re: No XChat in Dapper

On Wed, 2006-05-03 at 02:25 +0000, Peter Garrett wrote:
> How exactly is it a feature to expect people to use an app that isn't really purpose-designed for IRC ?

It's a feature that a good irc client has been removed from the distro,
because irc is not a particularly common use case. MSN is much more
common as a chat protocol, and since Gaim does both, it's a better
option than shipping two chat programs.

It's easy for those that like irc to install other programs.

> There are times when a new user is told to use certain commands in their IRC client that simply don't work in Gaim.

They should be told to install xchat, or another good irc client.

That is my opinion, at least.
--
<email address hidden>
gnupg pub 1024D/0E6B06FF

Revision history for this message
Guillaume Desmottes (cassidy) wrote :

I recently blogged [1] about this issue and explained why i think it's a bad idea to remove xchat-gnome.
To resume :

* The main argument for the removing of XChat-GNOME was that Gaim can be used for IRC chat and so it's redundant. Personally i don't like (and so don't use) Gaim for my jabber chat. I really don't love its interface not enough GNOME spirit and intuitive IMHO. It's the same for IRC and i'm not convinced than Gaim is a good tool for that. On the other side, the main goal of XChat-GNOME is the GNOME integration and its easy to use GUI.

* Another argument was that IRC chat is only used by geek and not by "common user". That's partially true but maybe it's just because current IRC client are too complicated and not enough user-friendly. ;)

* Furthermore, IRC will be used for the Ubuntu Live Chat Support. This spec aims to provide an easy way for user to ask support in their native language. Current implementation uses gaim and connects it on the channel of the good loco team (according user's locales configuration). So IRC chat is not reserved for geek anymore!

* The Sensible IRC handler spec aims to implement irc:// links handling like in XChat-GNOME. It would become useless if it was shipped by default.

* I don't think a lot of people use Gaim for IRC chat. But XChat-GNOME has more and more users and so feedback, bugreport, improvements, ... Furthermore, thanks to Sébastien, we have a very good co-operation with Ubuntu. Most of the fixes from HEAD version are quickly backported and integrated in the package.

* XChat-GNOME offers very sexy features like 3 notifications plugins (using sound, trayicon or libnotify). It's very useful to follow a conversation. Currently none is enabled by default but we could easily change that.

* XChat-GNOME is pretty small (only 500k for the .deb file). But if it's really a matter of space on the install CD, we could propose to install it the first time we launch the Live Chat Support.

[1] http://bigon.be/cassidy/blog/index.php?2006/04/29/55-irc-chat-on-ubuntu-dapper

Revision history for this message
Michiel Sikma (msikma) wrote :

I find that slightly bizarre. Since when is X-Chat as default program solely for people who "like IRC"? For one thing, it's about being able to give support to people. The Ubuntu channels are very well-populated and pretty much the easiest way for someone to quickly get help without having to register at a forum and post a topic. I've gone there many times and I've always managed to get my problem solved thanks to the volunteers that keep the channel running. It's an excellent method to fall back on for new users, since application documentation usually comes without or with only very basic troubleshooting.

Secondly, it could be argued that a program such as X-Chat makes it easily possible to access one of the frequently-used Internet protocols; why make such an important thing inaccessible by providing access solely through a program that doesn't do it right?

It's very easy to just include X-Chat and save a whole lot of users a whole lot of trouble. I think that this hamstrings the users for no reason at all (and no, "you can also do it with this inferior program" is not a reason).

Revision history for this message
Alexander van Loon (avanloon) wrote :

One of the basic things I'd expect in a default install of a Linux desktop distro is a specialised IRC client, I don't really care about getting support for Ubuntu. It's a pity that XChat-GNOME has been removed, Gaim's IRC functionality just won't cut it. Please get it back in. Besides e-mail and instant messaging, IRC is essential for communication for a lot of users.

Revision history for this message
Bruno Dusausoy (bdusauso) wrote :

I agree with people complaining about the removal of Xchat-Gnome.
Gaim's IRC support is quite basic and it is clearly not the easiest (nor the most friendly) way to connect to IRC.
Moreover, why should the Kubuntu users be able to use a "real" IRC client but not the Ubuntu ones ?
Kopete and Konversation are both installed by default, why wouldn't it be the same with Gaim and Xchat-Gnome ?

Revision history for this message
Andrew Conkling (andrewski) wrote :

I say y'all stop whining. If you want Xchat, you can install it. Gaim does IRC fine enough for use (it's all I use, actually), and it's a fine base client for those that don't use IRC often (whom Ubuntu is targetting AFAIK).

We're not removing it completely, folks, just not installing it by default. Since this has been discussed by the development team already, I'm closing this. If anyone wants to hear from the devs, check the recent thread on ubuntu-devel, and if anyone has any useful (i.e. not redundant) points to make, go ahead and reopen this.

Changed in ubuntu-meta:
status: Needs Info → Rejected
Revision history for this message
Michiel Sikma (msikma) wrote :

Excuse me? Stop whining?

We're raising valid points which you are not countering by the reasons the Ubuntu dev team might have had when they discussed this. Really, what is the response when we say that it's an extremely useful application that's vital to the users being able to find their way towards IRC when they need help?

Revision history for this message
Matthew East (mdke) wrote :

On Wed, 2006-05-03 at 13:23 +0000, michiel wrote:
> Really, what is the response when we say that
> it's an extremely useful application that's
> vital to the users being able to find their way
> towards IRC when they need help?

The response, as I understand it, is that IRC is not considered to be a
primary form of help, or rather, not sufficiently primary to warrant the
inclusion of a _second_ irc client.

In my view this is very well justified in two ways: 1) users find forums
much easier to navigate and obtain help, given that they are accessed by
a web browser, and 2) Gaim (while not the best irc client available) is
perfectly acceptable as an irc client, and can do lots of other chat
protocols too. It's simply not justifiable to include multiple chat
applications. Xchat-gnome can't do MSN at all, let alone as well as Gaim
does IRC. If you need more, please just install it.

Please bear in mind the code of conduct when phrasing further responses
to this bug (this applies to those supporting either side of the
argument).

Matt
--
<email address hidden>
gnupg pub 1024D/0E6B06FF

Revision history for this message
Andrew Conkling (andrewski) wrote :

The Live Support spec helps the user "find their way to IRC" by making it almost completely automated. A user that wants to benefit from the extra bells and whistles of Xchat can install it instead of or in addition to Gaim.

*An* IRC program is vital; I'll agree there. But using Gaim over Xchat when most people will be familiar with it (using it with IM protocols) seems like a good default to me.

Revision history for this message
Michiel Sikma (msikma) wrote :

I still find the rationale a bit skinny, personally. Like Andrew Conkling said, it's vital to have at least some way of connecting to IRC. Sure, GAIM does do this, but I don't understand how it isn't simply obligatory to include a program that specializes in providing access to a certain Internet protocol. By removing X-Chat as default application, Ubuntu will no longer have a specialized program to work with that protocol and more or less forces people to use a suboptimal alternative unless they go out and find a program that works better. It isn't as simple as "just installing it" if it's not known which application one needs to get.

I guess I can agree with the Live Support program covering a user's need to get support.

Revision history for this message
Peter Garrett (peter-garrett) wrote :

On Wed, 03 May 2006 13:13:04 -0000
Andrew Conkling <email address hidden> wrote:

> Since this has been discussed by the development team already, I'm closing this.

If this is a reason to close the bug, then I fear for the future of
Ubuntu as a community.

Is the community supposed to meekly accept the judgements of the dev team?
And where is it written that the dev team knows best?

In some quarters, such an attitude would be regarded as arrogant.

Sorry, but this kind of statement really riles people. I suggest that the
dev team needs to listen to the community respectfully, and consider
opinions other than its own.

Peter

 --

"Hyperlinks subvert hierarchy."

-The Cluetrain Manifesto

Revision history for this message
Peter Garrett (peter-garrett) wrote : Re: [Bug 38694] Re: [Bug 38694] Re: No XChat in Dapper

On Wed, 03 May 2006 13:40:24 -0000
Matthew East <email address hidden> wrote:

> Please bear in mind the code of conduct when phrasing further responses
> to this bug (this applies to those supporting either side of the
> argument).

So far I haven't seen anything that even remotely breaks the code of
conduct in this discussion. I think invoking the code of conduct is quite
inappropriate, and looks like an attempt to gag dissent.

Robust discussion is important and positive.

Peter
 --

"Hyperlinks subvert hierarchy."

-The Cluetrain Manifesto

Revision history for this message
Matthew East (mdke) wrote : Re: [Bug 38694] Re: [Bug 38694] Re: [Bug 38694] Re: No XChat in Dapper

On Wed, 2006-05-03 at 21:30 +0000, Peter Garrett wrote:
> On Wed, 03 May 2006 13:40:24 -0000
> Matthew East <email address hidden> wrote:
>
> > Please bear in mind the code of conduct when phrasing further responses
> > to this bug (this applies to those supporting either side of the
> > argument).
>
> So far I haven't seen anything that even remotely breaks the code of
> conduct in this discussion. I think invoking the code of conduct is quite
> inappropriate, and looks like an attempt to gag dissent.

This is off topic for the bug, but since you imply that my comment was
an attempt to gag dissent, I'll clarify: I was referring to the phrase
(used twice on this bug) - "stop whining". Given that it was used by
people who are agreeing with my view, I'm a bit surprised that I'm
accused of gagging dissent. Anyway, any further discussion of this can
be emailed to me privately, let's concentrate on the bug in hand.

Matt
--
<email address hidden>
gnupg pub 1024D/0E6B06FF

Revision history for this message
Constantine Evans (cevans) wrote :

I think the problem here could be solved if gaim were to improve IRC support.

As it is now, gaim performs very poorly in large chatrooms, which is precisely the type of chatroom that Live Support will be using. There is a significant lag, it seems to use more resources, and there is no highlighting. In #ubuntu, it is very difficult to keep track of anything without highlighting.

It also defaults to too small a window size, and when the window is resized, the buttons become far too large.

If these issues were fixed, I think that removing xchat-gnome would be a good idea.

Revision history for this message
Ewan Mac Mahon (ewan-macmahon) wrote :

Where was this discussed by the devs? I've just been back over the ubuntu-devel list archives and I'm not seeing a 'let's remove xchat' thread anywhere.

Revision history for this message
Matthew East (mdke) wrote : Re: [Bug 38694] Re: No XChat in Dapper

On Sun, 2006-05-07 at 14:34 +0000, Ewan Mac Mahon wrote:
> Where was this discussed by the devs? I've just been back over the
> ubuntu-devel list archives and I'm not seeing a 'let's remove xchat'
> thread anywhere.

As far as I know it wasn't discussed on the mailing list. It is likely
that the discussion took place during a conference/sprint or simply just
privately.

Matt
--
<email address hidden>
gnupg pub 1024D/0E6B06FF

Revision history for this message
Dana Olson (adolson) wrote :

Sometimes developers don't know what is best for their user base.

But in this instance, I think the decision is fine.

Xchat-gnome has issues in itself (removing features such as the clear chat buffer option, meaning I can't hit CTRL+L as I could before, and can in Gaim). I still use it currently despite that, but I can install it afterwords if I want. Or I can install Xchat if I want to. Or anything else for that matter.

It's really not hard to install an IRC client if you need one more robust than Gaim. I won't be using Gaim for IRC, and I won't be using the Live Support option from the help menu. So, the decision doesn't affect me in any way, aside from now, removing the Xchat-gnome app doesn't remove ubuntu-desktop with it. So that's a good thing.

For new users - the ones who will be most likely to use that menu option - using Gaim is a good option, and I think that those who know no better - don't even know what IRC is - will appreciate the apparent integration of such a help system into their MSN/Yahoo/AIM client.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers