[k8s]: For multi cluster support in k8s, project name is prepended with cluster name. Test infra needs to handle that

Bug #1778179 reported by Pulkit Tandon on 2018-06-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Juniper Openstack
Status tracked in Trunk
R5.0
Fix Released
High
Pulkit Tandon
Trunk
Fix Released
High
Pulkit Tandon

Bug Description

[k8s]: For multi cluster support in k8s, project name is prepended with cluster name. Test infra needs to handle that

Review in progress for https://review.opencontrail.org/44041
Submitter: Pulkit Tandon (<email address hidden>)

Review in progress for https://review.opencontrail.org/44042
Submitter: Pulkit Tandon (<email address hidden>)

Review in progress for https://review.opencontrail.org/44041
Submitter: Pulkit Tandon (<email address hidden>)

Review in progress for https://review.opencontrail.org/44042
Submitter: Pulkit Tandon (<email address hidden>)

Reviewed: https://review.opencontrail.org/44041
Committed: http://github.com/Juniper/contrail-test/commit/0603e8f7b7a39f760ab06a278583caf5c570f87b
Submitter: Zuul v3 CI (<email address hidden>)
Branch: master

commit 0603e8f7b7a39f760ab06a278583caf5c570f87b
Author: Pulkit Tandon <email address hidden>
Date: Fri Jun 22 11:42:14 2018 +0530

For k8s multi cluster support, the project names will be prepended by
cluster name of kubernetes.

Thus, making corresponding changes in the test infra to handle it.

Change-Id: I681724e6de0c6c1f5fb47c8735dbe1e0a4088e90
Closes-bug: #1778179

Review in progress for https://review.opencontrail.org/44042
Submitter: Pulkit Tandon (<email address hidden>)

Review in progress for https://review.opencontrail.org/44251
Submitter: Pulkit Tandon (<email address hidden>)

Reviewed: https://review.opencontrail.org/44251
Committed: http://github.com/Juniper/contrail-test/commit/d5781a8f7893a3821c9909025b6863e0e33c8354
Submitter: Zuul v3 CI (<email address hidden>)
Branch: master

commit d5781a8f7893a3821c9909025b6863e0e33c8354
Author: Pulkit Tandon <email address hidden>
Date: Fri Jun 29 20:41:26 2018 +0530

Replace a "_" with "-".

Change-Id: I97a68f7e7e261d5bc0b35912bd235699bd9007b4
Closes-bug: #1778179

Reviewed: https://review.opencontrail.org/44042
Committed: http://github.com/Juniper/contrail-test/commit/f19773e2afb55c76e468cc0f817369e76efe0b6a
Submitter: Zuul v3 CI (<email address hidden>)
Branch: R5.0

commit f19773e2afb55c76e468cc0f817369e76efe0b6a
Author: Pulkit Tandon <email address hidden>
Date: Fri Jun 22 11:42:14 2018 +0530

For k8s multi cluster support, the project names will be prepended by
cluster name of kubernetes.

Thus, making corresponding changes in the test infra to handle it.

Change-Id: I681724e6de0c6c1f5fb47c8735dbe1e0a4088e90
Closes-bug: #1778179

Pulkit Tandon (pulkitt) wrote :

Recent runs happened on build R5.0-133 and master-174.
The problem is fixed. Hence closing the bug

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers