R4.1-redhat deployment failed. Error:-resource validation failed

Bug #1750699 reported by shajuvk on 2018-02-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Juniper Openstack
Status tracked in Trunk
R4.1
Fix Committed
Critical
alexey-mr
R5.0
Fix Committed
Critical
alexey-mr
Trunk
Fix Committed
Critical
alexey-mr

Bug Description

                                                                                                 u'status': u"<% $.get('status', 'SUCCESS') %>"},
                                                                                          u'type': u'tripleo.deployment.v1.deploy_plan'}},
                                                                  u'queue_name': u'<% $.queue_name %>'},
                                                       u'name': u'send_message',
                                                       u'on-success': [{u'fail_workflow': u'<% $.get(\'status\') = "FAILED" %>'}],
                                                       u'retry': u'count=5 delay=1',
                                                       u'type': u'direct',
                                                       u'version': u'2.0'},
                                     u'set_deployment_failed': {u'name': u'set_deployment_failed',
                                                                u'on-success': u'send_message',
                                                                u'publish': {u'message': u'<% task(deploy).result %>',
                                                                             u'status': u'FAILED'},
                                                                u'type': u'direct',
                                                                u'version': u'2.0'},
                                     u'set_stack_in_progress': {u'name': u'set_stack_in_progress',
                                                                u'on-success': u'send_message',
                                                                u'publish': {u'message': u'The Heat stack is busy.',
                                                                             u'status': u'FAILED'},
                                                                u'type': u'direct',
                                                                u'version': u'2.0'},
                                     u'set_validations_failed': {u'name': u'set_validations_failed',
                                                                 u'on-success': u'send_message',
                                                                 u'publish': {u'message': u'<% task(run_validations).result %>',
                                                                              u'status': u'FAILED'},
                                                                 u'type': u'direct',
                                                                 u'version': u'2.0'}},
                          u'version': u'2.0'}},
u'message': u'Failed to run action [action_ex_id=4b09dddc-12af-48d3-899e-495fa850c6e2, action_cls=\'<class \'mistral.actions.action_factory.DeployStackAction\'>\', attributes=\'{}\', params=\'{u\'skip_deploy_identifier\': False, u\'container\': u\'overcloud\', u\'timeout\': 240}\']\n ERROR: Failed to validate: Failed to validate: resources[0]: Failed to validate: resources.NodeExtraConfig: "conditions" is not a valid keyword inside a resource definition',
u'status': u'FAILED'}
[stack@undercloud ~]$ ir

shajuvk (shajuvk) wrote :

This looks like an upstream problem .

information type: Proprietary → Public
Jeba Paulaiyan (jebap) on 2018-02-22
Changed in juniperopenstack:
assignee: nobody → alexey-mr (alexey-morlang)
alexey-mr (alexey-morlang) wrote :

Set to incomplete state to underline that it is not Juniper bug, it is TripleO bug:
Wrong section "conditions:" inside resource definition:

extraconfig/pre_deploy/rhel-registration/rhel-registration.yaml

UpdateDeploymentAfterRHELRegistration:
   type: OS::Heat::SoftwareDeployment
   depends_on: RHELRegistrationDeployment
   conditions:
     update_requested: {get_param: UpdateOnRHELRegistration}
   properties:
     name: UpdateDeploymentAfterRHELRegistration
     config: {get_resource: YumUpdateConfigurationAfterRHELRegistration}
     server: {get_param: server}
     actions: [‘CREATE’] # Only do this on CREATE

Linh Phan (lphan) wrote :

Hi guys I'm running into this same problem RHEL7.4/RHOSP11/Contrail4.1, do we have a fix yet ?

u'message': u'Failed to run action [action_ex_id=bc58fac6-8eb4-4c40-ac85-a4342ff86cd8, action_cls=\'<class \'mistral.actions.action_factory.DeployStackAction\'>\', attributes=\'{}\', params=\'{u\'skip_deploy_identifier\': False, u\'container\': u\'overcloud\', u\'timeout\': 240}\']\n

ERROR: Failed to validate: Failed to validate: resources[0]: Failed to validate: resources.NodeExtraConfig: "conditions" is not a valid keyword inside a resource definition',
 u'status': u'FAILED'}

Guil Barros (gbarros-r) wrote :
shajuvk (shajuvk) wrote :

After applying patch rpm openstack-tripleo-heat-templates-5.3.8-4.el7ost.noarch.rpm still seeing the issue. reopening the bug

alexey-mr (alexey-morlang) wrote :

1) Have you checked that it is really fixed there? Could you look is there still 'conditions:' inside the type UpdateDeploymentAfterRHELRegistration: in the file:
extraconfig/pre_deploy/rhel-registration/rhel-registration.yaml

2) Could you ensure you updated (after rmp update) the copy of THT that is used for deploy, just because usually we do copy of THT and then do changes there and then do deploy stack from copy of THT.

Jeba Paulaiyan (jebap) on 2018-05-09
tags: added: sanity
removed: sanityblocker
tikitavi (rtikitavi) wrote :

isn't reproduced

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.