Agent crash when using introspect ShowGratuitousArpCache

Bug #1712189 reported by chhandak on 2017-08-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Juniper Openstack
Status tracked in Trunk
R3.2
Fix Released
High
sangarshan p
R4.0
Fix Committed
High
sangarshan p
R4.1
Fix Released
High
sangarshan p
R5.0
Fix Committed
High
sangarshan p
Trunk
Fix Committed
High
sangarshan p

Bug Description

Agent crash when using below agent intropect

http://10.87.66.153:8085/services.xml#Snh_ShowGratuitousArpCache

(gdb)
#0 0x00007f12319f34cc in std::string::assign(std::string const&) () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
#1 0x0000000000d14e41 in ArpSandesh::SetArpEntry(ArpKey const&, ArpEntry const*) ()
#2 0x0000000000d155b7 in ShowGratuitousArpCache::HandleRequest() const ()
#3 0x00000000013a3a0d in Sandesh::ProcessRecv(SandeshRequest*) ()
#4 0x00000000013b0c84 in QueueTaskRunner<SandeshRequest*, WorkQueue<SandeshRequest*> >::Run() ()
#5 0x000000000149c187 in TaskImpl::execute() ()
#6 0x00007f1231c5cb3a in ?? () from /usr/lib/libtbb.so.2
#7 0x00007f1231c58816 in ?? () from /usr/lib/libtbb.so.2
#8 0x00007f1231c57f4b in ?? () from /usr/lib/libtbb.so.2
#9 0x00007f1231c540ff in ?? () from /usr/lib/libtbb.so.2
#10 0x00007f1231c542f9 in ?? () from /usr/lib/libtbb.so.2
#11 0x00007f1231e78184 in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#12 0x00007f123115137d in clone () from /lib/x86_64-linux-gnu/libc.so.6

chhandak (chhandak) wrote :

Core copied at

ubuntu-build04:/auto/cores/1712189> ls -lrt
total 482616
-rwxrwxrwx 1 chhandak epbg 168398848 Aug 21 13:09 core.contrail-vroute.17617.5b8s38.1503343854
-rwxrwxrwx 1 chhandak epbg 301461504 Aug 21 13:09 core.contrail-vroute.3446.5b8s38.1503342655
-rwxrwxrwx 1 chhandak epbg 22383456 Aug 21 13:10 contrail-vrouter-agent

Changed in juniperopenstack:
importance: Undecided → Critical
assignee: nobody → Hari Prasad Killi (haripk)
milestone: none → r4.0.1.0
information type: Proprietary → Public
tags: added: vrouter
Changed in juniperopenstack:
importance: Critical → High
assignee: Hari Prasad Killi (haripk) → jayaramsatya (jayaramsatya)

Review in progress for https://review.opencontrail.org/34878
Submitter: jayaramsatya (<email address hidden>)

Review in progress for https://review.opencontrail.org/34952
Submitter: jayaramsatya (<email address hidden>)

Review in progress for https://review.opencontrail.org/34953
Submitter: jayaramsatya (<email address hidden>)

Reviewed: https://review.opencontrail.org/34952
Committed: http://github.com/Juniper/contrail-controller/commit/bb7e50fddf40e4f3cdf2a1f6e8d1819a1b298d14
Submitter: Zuul (<email address hidden>)
Branch: master

commit bb7e50fddf40e4f3cdf2a1f6e8d1819a1b298d14
Author: jayaramsatya <email address hidden>
Date: Thu Aug 24 23:46:37 2017 +0530

Gratuitous arp cache is having stale entries even after delete
of VRF or interface due to that crash is seen.
Timer functinality is also not getting triggered becuase of gratious arp
check miss. now it is enabled this will also ensures that entries will
removed from Gratuitous cache.
closes-bug: #1712189

Change-Id: I44699840cdfe6285272ff8e3f5b3baf79f84304b

Reviewed: https://review.opencontrail.org/34953
Committed: http://github.com/Juniper/contrail-controller/commit/001410158cf1cba54b6218e1e5eca600d0ff9a3b
Submitter: Zuul (<email address hidden>)
Branch: R3.2

commit 001410158cf1cba54b6218e1e5eca600d0ff9a3b
Author: jayaramsatya <email address hidden>
Date: Thu Aug 24 23:46:37 2017 +0530

Gratuitous arp cache is having stale entries even after delete
of VRF or interface due to that crash is seen.
Timer functinality is also not getting triggered becuase of gratious arp
check miss. now it is enabled this will also ensures that entries will
removed from Gratuitous cache.
closes-bug: #1712189

Change-Id: I44699840cdfe6285272ff8e3f5b3baf79f84304b

Reviewed: https://review.opencontrail.org/34878
Committed: http://github.com/Juniper/contrail-controller/commit/00e01c179d68fbf368e530ca77e562c5885743df
Submitter: Zuul (<email address hidden>)
Branch: R4.0

commit 00e01c179d68fbf368e530ca77e562c5885743df
Author: jayaramsatya <email address hidden>
Date: Thu Aug 24 23:46:37 2017 +0530

Gratuitous arp cache is having stale entries even after delete
of VRF or interface due to that crash is seen.
Timer functinality is also not getting triggered becuase of gratious arp
check miss. now it is enabled this will also ensures that entries will
removed from Gratuitous cache.
closes-bug: #1712189

Change-Id: I44699840cdfe6285272ff8e3f5b3baf79f84304b

Jeba Paulaiyan (jebap) wrote :

Developer confirmed that the fix is already present in R4.1 branch. Could be fixed as part of some other bug?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers