Contrail webui shows Error: Query Engine is not responding for most of the Nodes

Bug #1691840 reported by mnayakbomman@juniper.net on 2017-05-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Juniper Openstack
Status tracked in Trunk
R4.0
Undecided
mnayakbomman@juniper.net
Trunk
Undecided
mnayakbomman@juniper.net

Bug Description

Installed contrail (16.04 based containers) 4.0.0.0-4 for kubernetes cluster.

When we try to check the status of all the nodes (except Virtual Routers) it gives an error "Query Engine is not responding". However analytics node status shows as active. Except nodemanager which is a bug tracked by #1690596. Attaching a screenshot

root@5b6s13(analytics):/# contrail-status
== Contrail Analytics ==
contrail-collector: active
contrail-analytics-api: active
contrail-query-engine: active
contrail-alarm-gen: active
contrail-snmp-collector: active
contrail-topology: active
contrail-analytics-nodemgr: inactive (disabled on boot)

Sundaresan Rajangam (srajanga) wrote :

Can you please provide the /var/log/contrail/contrail-query-engine.log*
Seems like query-engine crashed on receiving the request, but coredump was not generated - https://bugs.launchpad.net/juniperopenstack/+bug/1691691

Can you run "ulimit -c unlimited" and try the query again?

information type: Proprietary → Public
Rahul (rahuls) on 2017-05-19
tags: added: analytics
removed: ui
Changed in juniperopenstack:
assignee: nobody → Raj Reddy (rajreddy)
Raj Reddy (rajreddy) on 2017-05-19
Changed in juniperopenstack:
assignee: Raj Reddy (rajreddy) → Sundaresan Rajangam (srajanga)
Changed in juniperopenstack:
status: New → Incomplete
assignee: Sundaresan Rajangam (srajanga) → mnayakbomman@juniper.net (mnayakbomman)

Closing this bug, as I am not seeing the same issue with 4.0.0.0-6

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments