[qos]: Fabric based qos config not working

Bug #1606448 reported by Pulkit Tandon on 2016-07-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Juniper Openstack
New
High
Anand H. Krishnan
R3.1
New
High
Anand H. Krishnan

Bug Description

BUG Template : Ubuntu

OS version: 3.13.0-85-generic #129-Ubuntu
Contrail Version: 3.1.0.0-3
  (Debug build with fixes by Anand and Naveen)

root@nodeg31:~# vrouter —info
vRouter module version 2.22.2 (Built by anandhk@nodee2 on 2016-07-18 06:20:28.172146)

Setup details:
Multi node setup.
Testbed file attached

Configurations and Description:
Created a L2 only VN.
Created a Fabric Qos config and added a Vlan priority based mapping on it.
Launched 3 instances in that VM all on different compute nodes.

Send tagged L2 Broadcast traffic from one of the compute node nodeh8.
The data is received by 2nd node(nodeg31) into the fabric and forwarded from 2nd node(nodeg31) to 3rd node(nodec28) out from the Fabric.
Expected the Fabric OUT data to be marked.
No marking happened anywhere.

After debugging, we got to know that the inner packet is not looked upon while forwarding at the 2nd hop.
As, the current implementation has classification based on inner packet, no marking happened.

Thus, irrespective of vlan dot1p, ip dscp or mpls exp, as inner packet is not looked while forwarding Bcast/Mcast traffic,
we cannot have fabric based classification and marking in any case.

Pulkit Tandon (pulkitt) wrote :
Changed in juniperopenstack:
milestone: r3.1.0.0-fcs → none
tags: added: releasenote
Changed in juniperopenstack:
importance: Critical → High
information type: Proprietary → Public
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments