fails when trying to use openstack or any other S3 service on a non default port as a provider

Reported by Andrew Glen-Young on 2011-08-11
36
This bug affects 4 people
Affects Status Importance Assigned to Milestone
pyjuju
Critical
Clint Byrum
txAWS
Undecided
Unassigned
txaws (Ubuntu)
High
Clint Byrum

Bug Description

Ensemble should provide support for using Openstack as a provider/environment.

Openstack provides an EC2 compatible API for creating, runnning and managing virtual instances which Ensemble should support.

Testing
-------

I have attempted to replace Openstack URIs and keys in my ~/.ensemble/environments.yaml and run 'ensemble bootstrap' which fails with a 'Gateway Time-out'.

~/.ensemble/environments.yaml:

    ensemble: environments

    environments:
      openstack:
        type: ec2
        control-bucket: ensemble-[redacted]
        admin-secret: [redacted]
        ec2-uri: http://172.16.16.1:8773/services/Cloud
        s3-uri: http://172.16.16.1:3333
        access-key: [redacted]:user_project
        secret-key: [redacted]

Running ensemble:

    $ensemble bootstrap
    2011-08-11 10:27:57,054 INFO Bootstrapping environment 'openstack' (type: ec2)...
    504 Gateway Time-out
    2011-08-11 10:29:00,168 ERROR 504 Gateway Time-out

Network activity:

    $ sudo ss -ntp
    State Recv-Q Send-Q Local Address:Port Peer Address:Port
    [...]
    ESTAB 0 0 192.168.0.38:47284 172.16.16.1:80 users:(("ensemble",3313,5))

Clint Byrum (clint-fewbar) wrote :

Looks like txaws doesn't parse the s3-uri properly.

Changed in ensemble:
status: New → Confirmed
importance: Undecided → Critical
Changed in txaws:
status: New → Confirmed
Changed in ensemble:
status: Confirmed → Triaged
summary: - ensemble should support openstack as a provider
+ fails when trying to use openstack as a provider
summary: - fails when trying to use openstack as a provider
+ fails when trying to use openstack or any other S3 service on a non
+ default port as a provider
Changed in txaws (Ubuntu):
importance: Undecided → High
status: New → Triaged
milestone: none → ubuntu-11.10-beta-1
Changed in ensemble:
milestone: none → eureka
Tom Ellis (tellis) wrote :

After adding the patch, I get:

$ ensemble -v bootstrap
2011-08-18 09:00:17,857 DEBUG Initializing ensemble bootstrap runtime
2011-08-18 09:00:17,888 INFO Bootstrapping environment 'openstack' (type: ec2)...
Traceback (most recent call last):
Failure: twisted.web.error.Error: 404 Not Found
2011-08-18 09:00:17,894 ERROR Traceback (most recent call last):
Failure: twisted.web.error.Error: 404 Not Found

404 Not Found
2011-08-18 09:00:17,894 ERROR 404 Not Found

Excerpts from Tom Ellis's message of Thu Aug 18 13:00:31 UTC 2011:
> After adding the patch, I get:
>
> $ ensemble -v bootstrap
> 2011-08-18 09:00:17,857 DEBUG Initializing ensemble bootstrap runtime
> 2011-08-18 09:00:17,888 INFO Bootstrapping environment 'openstack' (type: ec2)...
> Traceback (most recent call last):
> Failure: twisted.web.error.Error: 404 Not Found
> 2011-08-18 09:00:17,894 ERROR Traceback (most recent call last):
> Failure: twisted.web.error.Error: 404 Not Found
>
> 404 Not Found
> 2011-08-18 09:00:17,894 ERROR 404 Not Found

As do I. If I get anything at all.. sometimes nova-objectstore just times
out.

It may be that objecstore doesn't implement all methods properly, its not
clear just yet.

I'm unable to test, since Canonistack seems to have the S3 service turned
off entirely.

$ txaws-list-buckets -a $AWS_SECRET_ACCESS_KEY -s $AWS_ACCESS_KEY_ID -U $S3_URL
Connection was refused by other side: 111: Connection refused.

So hopefully that will be back up and available soon so we can test Ensemble
against it.

Either way, I believe the 404 handling is a separate bug.

Andrew Glen-Young (aglenyoung) wrote :

On Thu 18-08-2011 15:43 ›, Clint Byrum wrote:
>
> As do I. If I get anything at all.. sometimes nova-objectstore just times
> out.
>
> It may be that objecstore doesn't implement all methods properly, its not
> clear just yet.
>
> I'm unable to test, since Canonistack seems to have the S3 service turned
> off entirely.
>
> $ txaws-list-buckets -a $AWS_SECRET_ACCESS_KEY -s $AWS_ACCESS_KEY_ID -U $S3_URL
> Connection was refused by other side: 111: Connection refused.
>
> So hopefully that will be back up and available soon so we can test Ensemble
> against it.
>
> Either way, I believe the 404 handling is a separate bug.
>

We recently upgraded nova-objectstore and it reverted our changes to the
init script (LP#820360). I've reverted the change and restarted the service
which should now be listening on the correct IP address and port.

--
Regards.
Andrew Glen-Young

Martin Pitt (pitti) on 2011-08-31
Changed in txaws (Ubuntu):
milestone: ubuntu-11.10-beta-1 → ubuntu-11.10-beta-2
Changed in txaws (Ubuntu):
assignee: nobody → Clint Byrum (clint-fewbar)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package txaws - 0.2-0ubuntu3

---------------
txaws (0.2-0ubuntu3) oneiric; urgency=low

  * debian/patches/fix-handling-nova-securitygroups.patch,
    debian/patches/fix-s3-alternate-port.patch: Fix txaws compatibility
    with OpenStack Nova. (LP: #829609 , LP: #824403)
 -- Clint Byrum <email address hidden> Thu, 15 Sep 2011 13:13:16 -0700

Changed in txaws (Ubuntu):
status: In Progress → Fix Released
Changed in txaws:
status: Confirmed → Fix Committed
Changed in juju:
assignee: nobody → Kapil Thangavelu (hazmat)
assignee: Kapil Thangavelu (hazmat) → Clint Byrum (clint-fewbar)
status: Triaged → Fix Released
Changed in txaws:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers