juju ssh [openssh options] not working

Bug #1979255 reported by Derek DeMoss

This bug report will be marked for expiration in 1 days if no further activity occurs. (find out why)

12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
juju
Incomplete
Undecided
Unassigned

Bug Description

Using Juju 2.9.31-ubuntu-amd64 on Ubuntu 18.04 LTS

Attempting to run `juju ssh 359 -J jumpbox.fqdn` gives me the same error as if I just attempt to connect directly: `ERROR cannot connect to any address: [ip.address:22]`

It appears to be dropping all of the OpenSSH options here.

Thanks!

Revision history for this message
Juan M. Tirado (tiradojm) wrote :

Could you provide some commands to replicate this scenario? I just tried with my local settings and it worked.

Changed in juju:
status: New → Incomplete
Revision history for this message
Heitor (heitorpbittencourt) wrote :

Does `juju ssh 259 -v` give the OpenSSH debug info?

Revision history for this message
Derek DeMoss (derek-omnivector) wrote :

Hey Juan!
Unfortunately it'll be slightly annoying to detect if this is triggered (for the -J option specifically) as you'd have to block network access to the deployed machine from the Juju client host and then have another host setup that could act as a jumpbox (with access to both).

I verified Heitor's suggestion does not produce any additional output, so it seem to be ignoring all of the OpenSSH options, and that's probably a safe way to troubleshoot it.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers