juju fails to provision lxd containers with lxd 4.18

Bug #1942864 reported by Frode Nordahl
82
This bug affects 16 people
Affects Status Importance Assigned to Milestone
juju
High
Ian Booth

Bug Description

This happens for juju 2.8.11, 2.9.11 and 2.9.12. On one of the machines I can see this in machine-0.log:

2021-09-07 08:04:58 ERROR juju.worker.dependency engine.go:671 "broker-tracker" manifold worker returned unexpected error: no container types determined
2021-09-07 08:04:58 INFO juju.worker.authenticationworker worker.go:103 "machine-0" key updater worker started
2021-09-07 08:04:58 INFO juju.container-setup container_initialisation.go:110 initial container setup with ids: [0/lxd/0]
2021-09-07 08:04:58 INFO juju.packaging.manager run.go:88 Running: snap info lxd
2021-09-07 08:04:58 INFO juju.worker.machiner machiner.go:112 "machine-0" started
2021-09-07 08:04:59 INFO juju.container.lxd initialisation_linux.go:300 switching LXD snap channel from 4.0/stable/ubuntu-20.04 to latest/stable
2021-09-07 08:04:59 INFO juju.packaging.manager run.go:88 Running: snap refresh --channel latest/stable lxd
2021-09-07 08:05:18 WARNING juju.container-setup container_initialisation.go:139 not stopping machine agent container watcher due to error: setting up container dependencies on host machine: Not Found
2021-09-07 08:05:18 ERROR juju.container-setup container_initialisation.go:118 starting container provisioner for lxd: setting up container dependencies on host machine: Not Found
2021-09-07 08:05:21 INFO juju.container-setup container_initialisation.go:110 initial container setup with ids: [0/lxd/0]
2021-09-07 08:05:21 INFO juju.packaging.manager run.go:88 Running: snap info lxd
2021-09-07 08:05:22 INFO juju.container.lxd initialisation_linux.go:295 LXD snap is already installed (channel: latest/stable); skipping package installation

Issuing `juju model-config lxd-snap-channel=4.17/stable` prior to deploying anything appears to fix/work around the issue.

Revision history for this message
Nikolay Vinogradov (nikolay.vinogradov) wrote :

Same happened to my deployment as well.

Revision history for this message
Sérgio Manso (sergiomanso) wrote :

I'm facing this same problem with lxd 4.18 and Juju 2.8.11

Revision history for this message
Moula BADJI (moulab1) wrote :

Same bug with juju 2.9.13 Dev.

Revision history for this message
Stéphane Graber (stgraber) wrote :

This is caused by Juju doing exact error string comparison against LXD's errors...

https://github.com/juju/juju/pull/13313

Revision history for this message
Michael Skalka (mskalka) wrote :

Tagging this as critical, it has rendered SQA unable to perform any baremetal master or stable testing.

tags: added: field-critical
John A Meinel (jameinel)
Changed in juju:
importance: Undecided → High
milestone: none → 2.9.13
status: New → In Progress
Revision history for this message
Ian Booth (wallyworld) wrote :

A fix using the newer StatusErrorMatch API is here

https://github.com/juju/juju/pull/13315

Ian Booth (wallyworld)
Changed in juju:
assignee: nobody → Ian Booth (wallyworld)
Ian Booth (wallyworld)
Changed in juju:
status: In Progress → Fix Committed
Revision history for this message
Pedro Guimarães (pguimaraes) wrote :

We just hit this bug on our deployment as well

Revision history for this message
Steven Parker (sbparke) wrote :

Confirming work around works for 9.12 with focal.

I found using the model-defaults was a little easier when deploying multiple models for testing.

juju model-defaults lxd-snap-channel=4.17/stable

Ian Booth (wallyworld)
Changed in juju:
milestone: 2.9.13 → 2.9.14
Changed in juju:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers