Unable to deploy bundle with sidecar and pod_spec charms

Bug #1928796 reported by Dominik Fleischmann
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
juju
High
Heather Lanigan

Bug Description

When trying to deploy a bundle which contains both sidecar charms and pod spec charms the sidecar charms get stuck with the following status-log:

Time Type Status Message
18 May 2021 11:44:09Z juju-unit allocating
18 May 2021 11:44:11Z juju-unit allocating Started container charm-init
18 May 2021 11:44:12Z juju-unit allocating Started container dex-auth
18 May 2021 11:44:14Z juju-unit allocating Back-off pulling image "jujusolutions/charm-base:kubernetes-kubernetes"
18 May 2021 11:44:52Z juju-unit allocating Error: ErrImagePull
18 May 2021 11:45:03Z juju-unit allocating Back-off pulling image "jujusolutions/charm-base:kubernetes-kubernetes"
18 May 2021 11:45:03Z workload waiting installing agent

This does not happen when the charms are deployed one by one through the juju cli.

Steps to reproduce:

git clone https://github.com/canonical/dex-auth-operator.git
cd dex-auth-operator
git checkout sidecar
charmcraft build
cd ..
juju deploy ./bundle.yaml

With bundle.yaml being the following content:

bundle: kubernetes
applications:
  dex-auth:
    charm: ./dex-auth-operator/dex-auth.charm
    scale: 1
    resources:
      oci-image: quay.io/dexidp/dex:v2.28.1
  oidc-gatekeeper:
    charm: cs:oidc-gatekeeper
    scale: 1
relations:
  - [dex-auth:oidc-client, oidc-gatekeeper:oidc-client]

Revision history for this message
John A Meinel (jameinel) wrote :

So "jujusolutions/charm-base:kubernetes-kubernetes" doesn't exist as we switched to using the ubuntu versions as the tag ("jujusolutions/charm-base:ubuntu-21.04")

When I run charmcraft build on that tree, it generates a .charm that has this manifest:
bases:
- architectures:
  - amd64
  channel: '20.04'
  name: ubuntu
charmcraft-started-at: '2021-05-18T14:15:12.930507Z'
charmcraft-version: 0.10.0

So Juju should be trying to use charm-base:ubuntu-20.04 for dex-auth.charm

looking at
https://jaas.ai/oidc-gatekeeper

That looks to be a bit mixed, in that it is a v1 style metadata:
https://api.jujucharms.com/charmstore/v5/oidc-gatekeeper-53/archive/metadata.yaml

with 'series: kubernetes' but does also have a manifest.yaml:
https://api.jujucharms.com/charmstore/v5/oidc-gatekeeper-53/archive/manifest.yaml

Which has a very similar architecture stanza.

Can you include the output from 'juju --version' for your client and 'juju status' ?

Changed in juju:
status: New → Incomplete
status: Incomplete → Triaged
importance: Undecided → High
milestone: none → 2.9.3
Revision history for this message
Dominik Fleischmann (dominik.f) wrote :

Outputs:

ubuntu@ip-172-31-27-47:~$ juju --version
2.9.0-ubuntu-amd64

ubuntu@ip-172-31-27-47:~$ juju status
Model Controller Cloud/Region Version SLA Timestamp
dex microk8s-localhost microk8s/localhost 2.9.0 unsupported 15:08:13Z

App Version Status Scale Charm Store Channel Rev OS Address Message
dex-auth waiting 0/1 dex-auth local 0 kubernetes installing agent
oidc-gatekeeper res:oci-image@9bb01f7 active 1 oidc-gatekeeper charmstore stable 53 kubernetes 10.152.183.100

Unit Workload Agent Address Ports Message
dex-auth/0 waiting allocating 10.1.244.237 installing agent
oidc-gatekeeper/0* active idle 10.1.244.214 8080/TCP

Revision history for this message
Dominik Fleischmann (dominik.f) wrote :

Attached juju status as an image because my previous comment broke the formatting.

Changed in juju:
assignee: nobody → Yang Kelvin Liu (kelvin.liu)
status: Triaged → In Progress
Revision history for this message
John A Meinel (jameinel) wrote :
Changed in juju:
assignee: Yang Kelvin Liu (kelvin.liu) → nobody
Changed in juju:
milestone: 2.9.3 → 2.9.4
John A Meinel (jameinel)
Changed in juju:
assignee: nobody → Simon Richardson (simonrichardson)
Changed in juju:
milestone: 2.9.4 → 2.9.5
Revision history for this message
John A Meinel (jameinel) wrote :
Revision history for this message
John A Meinel (jameinel) wrote :
Changed in juju:
assignee: Simon Richardson (simonrichardson) → Heather Lanigan (hmlanigan)
Changed in juju:
milestone: 2.9.5 → 2.9.6
Changed in juju:
milestone: 2.9.6 → 2.9.7
Changed in juju:
status: In Progress → Fix Committed
Changed in juju:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.