Glitch with K8s sidecar deploy: remote charm modified version does not match agent's

Bug #1924677 reported by Ben Hoyt on 2021-04-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
juju
High
Yang Kelvin Liu

Bug Description

When I was deploying my snappass-test charm to a microk8s controller, it didn't deploy right away, and I saw a couple of logs in juju debug-log that seem concerning:

unit-snappass-test-0: 13:27:01 INFO juju.worker.uniter remote charm modified version (0) does not match agent's (2)
unit-snappass-test-0: 13:27:01 INFO juju.worker.uniter unit "snappass-test/0" shutting down: agent should be terminated

However, when I looked at it in a couple of minutes it had retried and deployed okay.

I believe this is after tearing down a model and re-adding (or at least removing an application and re-deploying). Harry says: "wondering if k8s still had the StatefulSet and it wasn't destroyed completely".

Full record of commands and logs with more context: https://pastebin.canonical.com/p/Cn5TVXJyWY/

Harry Pidcock (hpidcock) on 2021-04-18
Changed in juju:
status: New → Triaged
John A Meinel (jameinel) wrote :

marking as incomplete as we don't have a clear reproducer yet.

Changed in juju:
status: Triaged → Incomplete
John A Meinel (jameinel) on 2021-04-20
Changed in juju:
milestone: 2.9-rc11 → 2.9.1
importance: Undecided → High
status: Incomplete → Triaged

I was able to 'juju deploy snappass-test' today and it very quickly
deployed and did not have these messages in the logs.
However, it sounds like this is a problem more for the
delete/deploy/delete/deploy cycle.

Doing a remove-application followed by another deploy, I did see:

controller-0: 11:37:48 WARNING juju.apiserver.caasapplicationprovisioner
ignoring non-existent unit with provider id "snappass-test-0"

But nothing otherwise worrying.

Trying 'juju destroy-model test; juju add-model test2' and then doing
another deploy:

Each test didn't give an error, and each test showed snappass-test running
in significantly under 1min (mostly in the few seconds range).

On Tue, Apr 20, 2021 at 6:55 PM John A Meinel <email address hidden>
wrote:

> ** Changed in: juju
> Milestone: 2.9-rc11 => 2.9.1
>
> ** Changed in: juju
> Importance: Undecided => High
>
> ** Changed in: juju
> Status: Incomplete => Triaged
>
> --
> You received this bug notification because you are subscribed to juju.
> Matching subscriptions: juju bugs
> https://bugs.launchpad.net/bugs/1924677
>
> Title:
> Glitch with K8s sidecar deploy: remote charm modified version does not
> match agent's
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/juju/+bug/1924677/+subscriptions
>

Changed in juju:
status: Triaged → In Progress
assignee: nobody → Yang Kelvin Liu (kelvin.liu)
Yang Kelvin Liu (kelvin.liu) wrote :

https://github.com/juju/juju/pull/12933 will be landed to 2.9 to fix this issue

Ian Booth (wallyworld) on 2021-04-28
Changed in juju:
milestone: 2.9.1 → 2.9-rc13
status: In Progress → Fix Committed
milestone: 2.9-rc13 → 2.9.0
Changed in juju:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers