add support for MAAS and VSphere to add-image command

Bug #1880015 reported by james beedy
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
juju
High
Unassigned

Bug Description

I would like to use my custom images in MAAS and VSphere with juju. Can the add-image command support this?

Thanks!

Revision history for this message
Ian Booth (wallyworld) wrote :

I think it's possible with vSphere, will need to check what can be done with MAAS.

Changed in juju:
milestone: none → 2.8.1
status: New → Triaged
importance: Undecided → High
Revision history for this message
Erik Lönroth (sssler-scania) wrote :
Tim Penhey (thumper)
Changed in juju:
milestone: 2.8.1 → 2.8-next
Revision history for this message
Erik Lönroth (sssler-scania) wrote :
Ian Booth (wallyworld)
Changed in juju:
milestone: 2.8-next → 2.9.1
Ian Booth (wallyworld)
Changed in juju:
milestone: 2.9.1 → 2.9.2
Changed in juju:
milestone: 2.9.2 → 2.9.3
Revision history for this message
Pete Vander Giessen (petevg) wrote :

This bug is still open. (It didn't make it into the scope of work for the last round of vSphere fixes.)

Ian Booth (wallyworld)
Changed in juju:
milestone: 2.9.3 → 2.9-next
Revision history for this message
Heather Lanigan (hmlanigan) wrote :

add-image for vSphere works as of the changes for specifying a template with image metadata in juju 2.9.2, (https://bugs.launchpad.net/juju/+bug/1867154)

e.g.:
juju metadata add-image juju-ci-root/templates/focal-test-template --series focal

Where juju-ci-root is a directory in /<datastore>/vm/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers