ERROR cannot deploy bundle: cannot get model status: model not found

Bug #1838774 reported by Jason Hobbs on 2019-08-02
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
juju
High
Tim Penhey

Bug Description

Added 'openstack' model with credential 'maas_cloud_credentials' for user 'admin'
11:25:49 INFO juju.cmd supercommand.go:57 running juju [2.6.6 gc go1.10.4]
11:25:49 DEBUG juju.cmd supercommand.go:58 args: []string{"/snap/juju/8594/bin/juju", "deploy", "-m", "foundations-maas:openstack", "--debug", "config/bundle.yaml"}
11:25:49 INFO juju.juju api.go:67 connecting to API addresses: [10.246.65.50:17070 10.246.64.244:17070 10.246.64.242:17070]
11:25:49 DEBUG juju.api apiclient.go:1092 successfully dialed "wss://10.246.64.244:17070/model/ee2c235f-088b-4cfe-870c-938846d6ec03/api"
11:25:49 INFO juju.api apiclient.go:624 connection established to "wss://10.246.64.244:17070/model/ee2c235f-088b-4cfe-870c-938846d6ec03/api"
11:25:49 INFO juju.juju api.go:303 API endpoints changed from [10.246.64.244:17070 10.246.65.50:17070 10.246.64.242:17070] to [10.246.64.244:17070 10.246.64.242:17070 10.246.65.50:17070]
11:25:49 INFO juju.juju api.go:67 connecting to API addresses: [10.246.64.244:17070 10.246.64.242:17070 10.246.65.50:17070]
11:25:49 DEBUG juju.api apiclient.go:1092 successfully dialed "wss://10.246.64.244:17070/api"
11:25:49 INFO juju.api apiclient.go:624 connection established to "wss://10.246.64.244:17070/api"
11:25:49 DEBUG juju.api monitor.go:35 RPC connection died
ERROR cannot deploy bundle: cannot get model status: model "ee2c235f-088b-4cfe-870c-938846d6ec03" not found (not found)
11:25:49 DEBUG cmd supercommand.go:496 error stack:
model "ee2c235f-088b-4cfe-870c-938846d6ec03" not found (not found)
/build/juju/parts/juju/go/src/github.com/juju/juju/rpc/client.go:178:
/build/juju/parts/juju/go/src/github.com/juju/juju/api/apiclient.go:1187:
/build/juju/parts/juju/go/src/github.com/juju/juju/cmd/juju/application/bundle.go:298: cannot get model status
/build/juju/parts/juju/go/src/github.com/juju/juju/cmd/juju/application/bundle.go:153:
/build/juju/parts/juju/go/src/github.com/juju/juju/cmd/juju/application/deploy.go:964: cannot deploy bundle
/build/juju/parts/juju/go/src/github.com/juju/juju/cmd/juju/application/deploy.go:1410:

Jason Hobbs (jason-hobbs) wrote :
tags: added: cdo-qa
tags: added: foundations-engine
Tim Penhey (thumper) on 2019-08-02
Changed in juju:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Tim Penhey (thumper)
milestone: none → 2.6.7
Jason Hobbs (jason-hobbs) wrote :

Sub'd to field critical as this is causing most of our test runs to fail. I can't explain why this didn't occur in pre-release testing.

Heather Lanigan (hmlanigan) wrote :

I can get the same model not found error in 2.6.6/stable with:

$ juju add-model testme-again ; juju status
Added 'testme-again' model on localhost/localhost with credential 'localhost' for user 'admin'
ERROR model "783fc7c4-ee3a-475d-83d6-9a9048d56038" not found (not found)

Heather Lanigan (hmlanigan) wrote :

Jason, I worked on an intermittent unit test fail this week which would have the same result as what we're seeing here. I put the offending code behind a feature flag, the pr landed on 8/1. I am unable to reproduce with the tip of 2.6.

$ juju add-model testme-again ; juju status
Added 'testme-again' model on localhost/localhost with credential 'localhost' for user 'admin'
Model Controller Cloud/Region Version SLA Timestamp
testme-again heather localhost/localhost 2.6.6.1 unsupported 00:48:20Z

Model "admin/testme-again" is empty.

Note: the 2.6 branch didn't get a juju version increment commit during the release process. So you'll need to bootstrap with --build-agent until we get that fix early next week.

Download full text (3.6 KiB)

Thanks Heather - that helps.

That may explain why we didn't see it in testing either. Since it was on
2.6/candidate, it didn't find released tools and built its own.

On Fri, Aug 2, 2019 at 8:00 PM Heather Lanigan <email address hidden>
wrote:

> Jason, I worked on an intermittent unit test fail this week which would
> have the same result as what we're seeing here. I put the offending
> code behind a feature flag, the pr landed on 8/1. I am unable to
> reproduce with the tip of 2.6.
>
> $ juju add-model testme-again ; juju status
> Added 'testme-again' model on localhost/localhost with credential
> 'localhost' for user 'admin'
> Model Controller Cloud/Region Version SLA
> Timestamp
> testme-again heather localhost/localhost 2.6.6.1 unsupported
> 00:48:20Z
>
> Model "admin/testme-again" is empty.
>
> Note: the 2.6 branch didn't get a juju version increment commit during
> the release process. So you'll need to bootstrap with --build-agent
> until we get that fix early next week.
>
> --
> You received this bug notification because you are a member of Canonical
> Field Critical, which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/1838774
>
> Title:
> ERROR cannot deploy bundle: cannot get model status: model not found
>
> Status in juju:
> Triaged
>
> Bug description:
> Added 'openstack' model with credential 'maas_cloud_credentials' for
> user 'admin'
> 11:25:49 INFO juju.cmd supercommand.go:57 running juju [2.6.6 gc
> go1.10.4]
> 11:25:49 DEBUG juju.cmd supercommand.go:58 args:
> []string{"/snap/juju/8594/bin/juju", "deploy", "-m",
> "foundations-maas:openstack", "--debug", "config/bundle.yaml"}
> 11:25:49 INFO juju.juju api.go:67 connecting to API addresses: [
> 10.246.65.50:17070 10.246.64.244:17070 10.246.64.242:17070]
> 11:25:49 DEBUG juju.api apiclient.go:1092 successfully dialed "wss://
> 10.246.64.244:17070/model/ee2c235f-088b-4cfe-870c-938846d6ec03/api"
> 11:25:49 INFO juju.api apiclient.go:624 connection established to
> "wss://10.246.64.244:17070/model/ee2c235f-088b-4cfe-870c-938846d6ec03/api"
> 11:25:49 INFO juju.juju api.go:303 API endpoints changed from [
> 10.246.64.244:17070 10.246.65.50:17070 10.246.64.242:17070] to [
> 10.246.64.244:17070 10.246.64.242:17070 10.246.65.50:17070]
> 11:25:49 INFO juju.juju api.go:67 connecting to API addresses: [
> 10.246.64.244:17070 10.246.64.242:17070 10.246.65.50:17070]
> 11:25:49 DEBUG juju.api apiclient.go:1092 successfully dialed "wss://
> 10.246.64.244:17070/api"
> 11:25:49 INFO juju.api apiclient.go:624 connection established to
> "wss://10.246.64.244:17070/api"
> 11:25:49 DEBUG juju.api monitor.go:35 RPC connection died
> ERROR cannot deploy bundle: cannot get model status: model
> "ee2c235f-088b-4cfe-870c-938846d6ec03" not found (not found)
> 11:25:49 DEBUG cmd supercommand.go:496 error stack:
> model "ee2c235f-088b-4cfe-870c-938846d6ec03" not found (not found)
> /build/juju/parts/juju/go/src/github.com/juju/juju/rpc/client.go:178:
> /build/juju/parts/juju/go/src/github.com/juju/juju/api/apiclient.go:1187:
>
> /build/juju/parts/juju/go/src/
> github.com/juju/juju/cmd/juju/applicati...

Read more...

Heather Lanigan (hmlanigan) wrote :
Changed in juju:
status: Triaged → Fix Committed
Jason Hobbs (jason-hobbs) wrote :

We are hitting bug 1812191 when trying to use --build-agent

Richard Harding (rharding) wrote :

This shouldn't be hit with the changes Heather put in place. This is in QA solutions testing currently. You mention using --build-agent but not what branch/code was in use for that. I'm going to mark it fix committed for the moment with the goal of fix-released with the 2.6.7 release upcoming.

If I've missed what you meant or it does in fact happen with the changes that have been landed let me know.

Changed in juju:
milestone: 2.6.7 → 2.6.8
Changed in juju:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers