juju metadata generate image broken

Bug #1829044 reported by Ian Booth on 2019-05-14
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
juju
Critical
Yang Kelvin Liu

Bug Description

As per

https://discourse.jujucharms.com/t/juju-metadata-generate-image/1475

The issue is that environs.OpenParams expects a controller-uuid but this is not available from bootstrap-config file. For this metadata generation, we don't use the constructed environ for anything other than extraction some cloud info so controller-uuid could be omitted.

We should look to fix te 3 places that call

func prepare(context *cmd.Context, controllerName string, store jujuclient.ClientStore) (environs.Environ, error)

in github.com/juju/juju/cmd/plugins/juju-metadata/imagemetadata.go

Ian Booth (wallyworld) on 2019-05-14
Changed in juju:
importance: High → Critical
assignee: nobody → Yang Kelvin Liu (kelvin.liu)
Changed in juju:
milestone: 2.6.2 → 2.6.3
Yang Kelvin Liu (kelvin.liu) wrote :

https://github.com/juju/juju/pull/10196 PR will be merged to 2.6 to fix this issue.

Changed in juju:
status: Triaged → In Progress
Changed in juju:
status: In Progress → Fix Committed
Jason Hobbs (jason-hobbs) wrote :

sub'd to field critical

Richard Harding (rharding) wrote :

@Jason can you confirm that the fix is valid and works for you using the edge snap of the 2.6/edge track?

Thanks

Yes Rick, the 2.6/edge snap fix is working. We need a release with it.

On Tue, May 28, 2019 at 11:00 AM Richard Harding <email address hidden>
wrote:

> @Jason can you confirm that the fix is valid and works for you using the
> edge snap of the 2.6/edge track?
>
> Thanks
>
> --
> You received this bug notification because you are a member of Canonical
> Field Critical, which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/1829044
>
> Title:
> juju metadata generate image broken
>
> Status in juju:
> Fix Committed
>
> Bug description:
> As per
>
> https://discourse.jujucharms.com/t/juju-metadata-generate-image/1475
>
> The issue is that environs.OpenParams expects a controller-uuid but
> this is not available from bootstrap-config file. For this metadata
> generation, we don't use the constructed environ for anything other
> than extraction some cloud info so controller-uuid could be omitted.
>
> We should look to fix te 3 places that call
>
> func prepare(context *cmd.Context, controllerName string, store
> jujuclient.ClientStore) (environs.Environ, error)
>
> in github.com/juju/juju/cmd/plugins/juju-metadata/imagemetadata.go
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/juju/+bug/1829044/+subscriptions
>

Richard Harding (rharding) wrote :

Thanks, we're working to get a sha to QA solutions for testing tomorrow.

On Tue, May 28, 2019 at 12:20 PM Jason Hobbs <email address hidden>
wrote:

> Yes Rick, the 2.6/edge snap fix is working. We need a release with it.
>
> On Tue, May 28, 2019 at 11:00 AM Richard Harding <
> <email address hidden>>
> wrote:
>
> > @Jason can you confirm that the fix is valid and works for you using the
> > edge snap of the 2.6/edge track?
> >
> > Thanks
> >
> > --
> > You received this bug notification because you are a member of Canonical
> > Field Critical, which is subscribed to the bug report.
> > https://bugs.launchpad.net/bugs/1829044
> >
> > Title:
> > juju metadata generate image broken
> >
> > Status in juju:
> > Fix Committed
> >
> > Bug description:
> > As per
> >
> > https://discourse.jujucharms.com/t/juju-metadata-generate-image/1475
> >
> > The issue is that environs.OpenParams expects a controller-uuid but
> > this is not available from bootstrap-config file. For this metadata
> > generation, we don't use the constructed environ for anything other
> > than extraction some cloud info so controller-uuid could be omitted.
> >
> > We should look to fix te 3 places that call
> >
> > func prepare(context *cmd.Context, controllerName string, store
> > jujuclient.ClientStore) (environs.Environ, error)
> >
> > in github.com/juju/juju/cmd/plugins/juju-metadata/imagemetadata.go
> >
> > To manage notifications about this bug go to:
> > https://bugs.launchpad.net/juju/+bug/1829044/+subscriptions
> >
>
> --
> You received this bug notification because you are subscribed to juju.
> https://bugs.launchpad.net/bugs/1829044
>
> Title:
> juju metadata generate image broken
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/juju/+bug/1829044/+subscriptions
>

Changed in juju:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers