Segmentation fault during bootstrap

Bug #1828332 reported by Kenneth Koski
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
juju
Fix Released
High
Yang Kelvin Liu

Bug Description

I tried bootstrapping onto a microk8s 1.13/stable instance with Juju 2.7-beta1+develop-384b393 and got this backtrace:

23:26:22 + juju bootstrap microk8s-cloud microk8s-controller
23:26:30 Creating Juju controller "microk8s-controller" on microk8s-cloud/localhost
23:26:31 Creating k8s resources for controller "controller-microk8s-controller"
23:28:08
23:28:08 Now you can run
23:28:08 juju add-model <model-name>
23:28:08 to create a new model to deploy k8s workloads.
23:28:08 panic: runtime error: invalid memory address or nil pointer dereference
23:28:08 [signal SIGSEGV: segmentation violation code=0x1 addr=0x108 pc=0x13eb465]
23:28:08
23:28:08 goroutine 1 [running]:
23:28:08 github.com/juju/juju/caas/kubernetes/provider.(*controllerStack).getControllerConfigMap.func1(0xc420d85e28)
23:28:08 /build/juju/parts/juju/go/src/github.com/juju/juju/caas/kubernetes/provider/bootstrap.go:253 +0x25
23:28:08 github.com/juju/juju/caas/kubernetes/provider.(*controllerStack).getControllerConfigMap(0xc420174a80, 0x0, 0x33d54e0, 0xc4200d34a0)
23:28:08 /build/juju/parts/juju/go/src/github.com/juju/juju/caas/kubernetes/provider/bootstrap.go:272 +0x103
23:28:08 github.com/juju/juju/caas/kubernetes/provider.(*controllerStack).ensureControllerConfigmapBootstrapParams(0xc420174a80, 0x0, 0x0)
23:28:08 /build/juju/parts/juju/go/src/github.com/juju/juju/caas/kubernetes/provider/bootstrap.go:474 +0x139
23:28:08 github.com/juju/juju/caas/kubernetes/provider.(*controllerStack).Deploy(0xc420174a80, 0x0, 0x0)
23:28:08 /build/juju/parts/juju/go/src/github.com/juju/juju/caas/kubernetes/provider/bootstrap.go:320 +0x1fa
23:28:08 github.com/juju/juju/caas/kubernetes/provider.(*kubernetesClient).Bootstrap.func1(0x34216e0, 0xc4207fa8c0, 0xc42020e000, 0x1176592e000, 0x12a05f200, 0x2540be400, 0x0, 0x0)
23:28:08 /build/juju/parts/juju/go/src/github.com/juju/juju/caas/kubernetes/provider/k8s.go:349 +0x230
23:28:08 github.com/juju/juju/environs/bootstrap.bootstrapCAAS(0x34216e0, 0xc4207fa8c0, 0x7fbdc5265328, 0xc420c6ef80, 0x33e0c80, 0xc4202c58a0, 0x0, 0x0, 0x0, 0x0, ...)
23:28:08 /build/juju/parts/juju/go/src/github.com/juju/juju/environs/bootstrap/bootstrap.go:238 +0x33a
23:28:08 github.com/juju/juju/environs/bootstrap.Bootstrap(0x34216e0, 0xc4207fa8c0, 0x7fbdc5265328, 0xc420c6ef80, 0x33e0c80, 0xc4202c58a0, 0x0, 0x0, 0x0, 0x0, ...)
23:28:08 /build/juju/parts/juju/go/src/github.com/juju/juju/environs/bootstrap/bootstrap.go:561 +0x27b
23:28:08 github.com/juju/juju/cmd/juju/commands.bootstrapFuncs.Bootstrap(0x34216e0, 0xc4207fa8c0, 0x7fbdc5265328, 0xc420c6ef80, 0x33e0c80, 0xc4202c58a0, 0x0, 0x0, 0x0, 0x0, ...)
23:28:08 /build/juju/parts/juju/go/src/github.com/juju/juju/cmd/juju/commands/bootstrap.go:345 +0xa4
23:28:08 github.com/juju/juju/cmd/juju/commands.(*bootstrapCommand).Run(0xc420787b00, 0xc4207f4eb0, 0x0, 0x0)
23:28:08 /build/juju/parts/juju/go/src/github.com/juju/juju/cmd/juju/commands/bootstrap.go:744 +0x17a1
23:28:08 github.com/juju/juju/cmd/modelcmd.(*modelCommandWrapper).Run(0xc42080b4d0, 0xc4207f4eb0, 0xc42080b4d0, 0xc4202c51b0)
23:28:08 /build/juju/parts/juju/go/src/github.com/juju/juju/cmd/modelcmd/modelcommand.go:551 +0x128
23:28:08 github.com/juju/juju/cmd/modelcmd.(*baseCommandWrapper).Run(0xc4207fafe0, 0xc4207f4eb0, 0x0, 0x0)
23:28:08 /build/juju/parts/juju/go/src/github.com/juju/juju/cmd/modelcmd/base.go:472 +0xab
23:28:08 github.com/juju/juju/vendor/github.com/juju/cmd.(*SuperCommand).Run(0xc4203ce140, 0xc4207f4eb0, 0xc4207f4eb0, 0x0)
23:28:08 /build/juju/parts/juju/go/src/github.com/juju/juju/vendor/github.com/juju/cmd/supercommand.go:493 +0x2c0
23:28:08 github.com/juju/juju/vendor/github.com/juju/cmd.Main(0x34121a0, 0xc4203ce140, 0xc4207f4eb0, 0xc4200d4050, 0x3, 0x3, 0x2c41a60)
23:28:08 /build/juju/parts/juju/go/src/github.com/juju/juju/vendor/github.com/juju/cmd/cmd.go:379 +0x2d9
23:28:08 github.com/juju/juju/cmd/juju/commands.main.Run(0x318aea0, 0xc4200d4040, 0x4, 0x4, 0x0)
23:28:08 /build/juju/parts/juju/go/src/github.com/juju/juju/cmd/juju/commands/main.go:143 +0x1af
23:28:08 github.com/juju/juju/cmd/juju/commands.Main(0xc4200d4040, 0x4, 0x4, 0xc4200c0100)
23:28:08 /build/juju/parts/juju/go/src/github.com/juju/juju/cmd/juju/commands/main.go:89 +0x4b
23:28:08 main.main()
23:28:08 /build/juju/parts/juju/go/src/github.com/juju/juju/cmd/juju/main.go:37 +0x8c

Tags: k8s
Revision history for this message
Ian Booth (wallyworld) wrote :

Ugh. The root cause here is an error in bootstrap in which a post process operation fails and masks the original error. At this stage, I think the only thing you can do is microk8s.reset to start again. We'll fix juju to properly report the root cause error.

Changed in juju:
milestone: none → 2.6.1
status: New → Triaged
importance: Undecided → High
tags: added: k8s
Revision history for this message
Yang Kelvin Liu (kelvin.liu) wrote :

https://github.com/juju/juju/pull/10162/files is merging to 2.6 to fix this.
Thanks!

Changed in juju:
status: Triaged → In Progress
assignee: nobody → Yang Kelvin Liu (kelvin.liu)
Changed in juju:
milestone: 2.6.1 → 2.6.2
Changed in juju:
status: In Progress → Fix Committed
Changed in juju:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers