using bundle from export-bundle got: option "cpu-allocation-ratio" expected float, got 64

Bug #1815222 reported by Heather Lanigan on 2019-02-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
juju
High
Achilleas Anagnostopoulos
2.5
High
Achilleas Anagnostopoulos

Bug Description

With 2.5.1, deployed an openstack bundle, made a few changes and exported. Trying to deploy with the exported bundle and got:

ERROR cannot deploy bundle: cannot deploy application "nova-cloud-controller": option "cpu-allocation-ratio" expected float, got 64

From original bundle:
  nova-cloud-controller:
    annotations:
      gui-x: '0'
      gui-y: '500'
    charm: cs:nova-cloud-controller
    num_units: 1
    options:
      worker-multiplier: 0.1
      network-manager: Neutron
      openstack-origin: cloud:bionic-rocky
      ram-allocation-ratio: '64'
      cpu-allocation-ratio: '64'

From exported bundle:
  nova-cloud-controller:
    charm: cs:nova-cloud-controller-320
    num_units: 1
    to:
    - "19"
    options:
      cpu-allocation-ratio: 64
      network-manager: Neutron
      openstack-origin: cloud:bionic-rocky
      ram-allocation-ratio: 64
      worker-multiplier: 0.1

Changed 64 to '64' and the exported bundle deployed.

tags: added: bitesize bundles
Changed in juju:
importance: Undecided → High
Changed in juju:
assignee: nobody → Achilleas Anagnostopoulos (achilleasa)
status: Triaged → In Progress

This issue was caused by strict type-coercion rules (int -> float in particular) in `juju/schema`. The schema package had already been updated to support this but juju used an older dep. PR https://github.com/juju/juju/pull/9768 bumps the package dep in 2.5 and fixes this issue.

Changed in juju:
status: In Progress → Fix Committed
John A Meinel (jameinel) wrote :
Changed in juju:
milestone: none → 2.6-beta1
Changed in juju:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers