2.5-beta1: juju model-defaults non-zero exit status

Bug #1789288 reported by John George on 2018-08-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
juju
High
Unassigned

Bug Description

Just after bootstrap, juju model-defaults is called to set apt-https-proxy and apt-http-proxy but returns a non-zero exit code:
  juju model-defaults -c foundations-maas apt-https-proxy=http://squid.internal:3128 apt-http-proxy=http://squid.internal:3128

A juju-crashdump from the controller is attached and has the following errors in machine-0.log around the time of the failure:
2018-08-25 20:55:36 ERROR juju.worker.dependency engine.go:587 "lease-clock-updater" manifold worker returned unexpected error: updating global clock: lease operation timed out
2018-08-25 20:55:37 ERROR juju.worker.dependency engine.go:587 "lease-manager" manifold worker returned unexpected error: lease operation timed out
2018-08-25 20:55:37 ERROR juju.worker.dependency engine.go:587 "is-responsible-flag" manifold worker returned unexpected error: lease manager stopped
2018-08-25 20:55:37 ERROR juju.api.watcher watcher.go:92 error trying to stop watcher: write tcp 127.0.0.1:48512->127.0.0.1:17070: write: broken pipe
2018-08-25 20:55:37 ERROR juju.worker.dependency engine.go:587 "not-alive-flag" manifold worker returned unexpected error: watcher has been stopped (stopped)
2018-08-25 20:55:37 ERROR juju.worker.dependency engine.go:587 "not-dead-flag" manifold worker returned unexpected error: watcher has been stopped (stopped)
2018-08-25 20:55:37 ERROR juju.worker.dependency engine.go:587 "valid-credential-flag" manifold worker returned unexpected error: watcher has been stopped (stopped)
2018-08-25 20:55:37 ERROR juju.worker.dependency engine.go:587 "api-caller" manifold worker returned unexpected error: api connection broken unexpectedly
2018-08-25 20:55:37 ERROR juju.worker.dependency engine.go:587 "api-caller" manifold worker returned unexpected error: api connection broken unexpectedly

Changed in juju:
status: New → Triaged
importance: Undecided → High
milestone: none → 2.5.1
Ian Booth (wallyworld) on 2019-01-28
Changed in juju:
milestone: 2.5.1 → 2.5.2
Changed in juju:
milestone: 2.5.2 → 2.5.3
Changed in juju:
milestone: 2.5.3 → 2.5.4
Changed in juju:
milestone: 2.5.4 → 2.5.5
Changed in juju:
milestone: 2.5.6 → 2.5.8
Anastasia (anastasia-macmood) wrote :

I cannot reproduce this on current 2.6.4. I must have been fixed as part of other work in the area.

If you are still seeing this behavior, please open a new report with latest information - logs, etc.

Changed in juju:
status: Triaged → Fix Released
milestone: 2.5.8 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers