Creating backups does not work on Bionic controllers

Bug #1772887 reported by Eric Claude Jones
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
juju
High
Eric Claude Jones

Bug Description

To reproduce:

1. Bootstrap a bionic host `juju bootstrap <cloud> <name> --bootstrap-series=bionic`
2. Create a backup `juju create-backup`

You should receive the following output:

ERROR while creating backup archive: while dumping juju state database: error dumping databases: error executing "/usr/bin/mongodump": 2018-05-23T10:32:34.650+0000 error dialing localhost:37017: SSL errors: SSL routines:tls_process_server_certificate:certificate verify failed; 2018-05-23T10:32:35.158+0000 error dialing localhost:37017: SSL errors: SSL routines:tls_process_server_certificate:certificate verify failed; 2018-05-23T10:32:35.666+0000 error dialing localhost:37017: SSL errors: SSL routines:tls_process_server_certificate:certificate verify failed; 2018-05-23T10:32:36.675+0000 error dialing localhost:37017: SSL errors: SSL routines:tls_process_server_certificate:certificate verify failed; 2018-05-23T10:32:37.183+0000 error dialing localhost:37017: SSL errors: SSL routines:tls_process_server_certificate:certificate verify failed; 2018-05-23T10:32:37.690+0000 error dialing localhost:37017: SSL errors: SSL routines:tls_process_server_certificate:certificate verify failed; 2018-05-23T10:32:38.191+0000 Failed: error connecting to db server: no reachable servers;

$ juju version

> 2.4-beta3-bionic-amd64

$ juju controllers --refresh

> Controller Model User Access Cloud/Region Models Machines HA Version
> test* default admin superuser jujugui 2 1 none 2.4-beta3.1

I've tried this with both LXD and MAAS2.3 providers.

I've tried this on both Artful and Bionic client machines.

Changed in juju:
status: New → Triaged
importance: Undecided → High
milestone: none → 2.4-beta3
Changed in juju:
milestone: 2.4-beta3 → none
Revision history for this message
Eric Claude Jones (ecjones) wrote :
Changed in juju:
assignee: nobody → Eric Claude Jones (ecjones)
Changed in juju:
status: Triaged → Fix Committed
Revision history for this message
Doug Parrish (dparrish) wrote :

This is occurring on 2.3.8 Bionic as well. Will this be fixed in 2.3? Thanks.

Felipe Reyes (freyes)
tags: added: sts
Revision history for this message
Tim Penhey (thumper) wrote : Re: [Bug 1772887] Re: Creating backups does not work on Bionic controllers

Bionic controllers are not supported on 2.3. Bionic workloads are.

If it is working, it is more accidental than fully planned.

On 30/05/18 08:27, Doug Parrish wrote:
> This is occurring on 2.3.8 Bionic as well. Will this be fixed in 2.3?
> Thanks.
>

Revision history for this message
Felipe Reyes (freyes) wrote :

On Tue, May 29, 2018 at 11:54:28PM -0000, Tim Penhey wrote:
> Bionic controllers are not supported on 2.3. Bionic workloads are.

is it possible to print a big warning when a user attempts to use a
bionic controller with 2.3?, because I've seen people using 1.25 with
xenial bootstrap servers (in production), so it's not something rare
that no one will try to do.

 ~/sosreport-XXXX $ cat lsb-release
Description: Ubuntu 16.04.3 LTS
 ~/sosreport-XXXX $ grep jujud ps
root 31225 0.0 0.0 19700 2068 ? Ss Nov22 0:00 bash /var/lib/juju/init/jujud-machine-0/exec-start.sh
root 31230 0.6 0.3 1204956 52580 ? Sl Nov22 45:05 /var/lib/juju/tools/machine-0/jujud machine --data-dir /var/lib/juju --machine-id 0 --show-log --logging-config=<root>=TRACE
 ~/sosreport-XXXX $ grep "running jujud" var/log/juju/machine-0.log | head -n 1
2017-08-14 09:25:57 INFO juju.cmd supercommand.go:37 running jujud [1.25.12-xenial-amd64 gc]

Changed in juju:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers