Juju fails to launch containers when netplan includes bridge configuration

Bug #1771120 reported by Craig Bender on 2018-05-14
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
juju
High
John A Meinel
2.3
High
John A Meinel

Bug Description

Juju 2.4-beta2-bionic-amd64

br1 is maas configured bridge (bridge works fine from deployed machine standpoint

Rendered netplan yaml attached

Result of model when bridge has paramaters

        started 172.27.21.225 gm3b6t bionic default Deployed
0/lxd/0 down pending bionic bridge activation error: yaml: unmarshal errors:
  line 29: field parameters not found in struct netplan.Bridge
0/lxd/1 down pending bionic bridge activation error: yaml: unmarshal errors:
  line 29: field parameters not found in struct netplan.Bridge
0/lxd/2 down pending bionic bridge activation error: yaml: unmarshal errors:
  line 29: field parameters not found in struct netplan.Bridge
0/lxd/3 down pending bionic bridge activation error: yaml: unmarshal errors:
  line 29: field parameters not found in struct netplan.Bridge
1 started 172.27.21.226 qmmrxt bionic default Deployed
1/lxd/0 down pending bionic bridge activation error: yaml: unmarshal errors:
  line 29: field parameters not found in struct netplan.Bridge
1/lxd/1 down pending bionic bridge activation error: yaml: unmarshal errors:
  line 29: field parameters not found in struct netplan.Bridge
1/lxd/2 down pending bionic bridge activation error: yaml: unmarshal errors:
  line 29: field parameters not found in struct netplan.Bridge
1/lxd/3 down pending bionic bridge activation error: yaml: unmarshal errors:
  line 29: field parameters not found in struct netplan.Bridge
2 started 172.27.21.227 tpywwx bionic default Deployed
2/lxd/0 down pending bionic bridge activation error: yaml: unmarshal errors:
  line 29: field parameters not found in struct netplan.Bridge
2/lxd/1 down pending bionic bridge activation error: yaml: unmarshal errors:
  line 29: field parameters not found in struct netplan.Bridge
2/lxd/2 down pending bionic bridge activation error: yaml: unmarshal errors:
  line 29: field parameters not found in struct netplan.Bridge
2/lxd/3 down pending bionic bridge activation error: yaml: unmarshal errors:
  line 29: field parameters not found in struct netplan.Bridge
3 started 172.27.21.228 mgnayy bionic default Deployed
3/lxd/0 down pending bionic bridge activation error: yaml: unmarshal errors:
  line 29: field parameters not found in struct netplan.Bridge
3/lxd/1 down pending bionic bridge activation error: yaml: unmarshal errors:
  line 29: field parameters not found in struct netplan.Bridge
3/lxd/2 down pending bionic bridge activation error: yaml: unmarshal errors:
  line 29: field parameters not found in struct netplan.Bridge
4 started 172.27.21.231 phpkbm bionic default Deployed
5 started 172.27.21.230 nwnkwr bionic default Deployed
6 started 172.27.21.229 yemrsf bionic default Deployed

Craig Bender (craig-bender) wrote :
John A Meinel (jameinel) wrote :

The issue is not the bridges as much as the "parameters" struct as attributes of the bridge.

I have a patch that is adding the extra fields that we didn't support. *right now* it doesn't yet handle Bridge Parameters, but I'll add that today as part of that patch:
https://github.com/juju/juju/pull/8697

Changed in juju:
assignee: nobody → John A Meinel (jameinel)
importance: Undecided → High
milestone: none → 2.4-rc1
status: New → In Progress
John A Meinel (jameinel) wrote :

https://github.com/juju/juju/pull/8708 brings those changes into develop

John A Meinel (jameinel) on 2018-05-16
Changed in juju:
status: In Progress → Fix Committed
Changed in juju:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers