ERROR detecting credentials for "localhost" cloud provider: adding certificate "juju": Unknown request type

Bug #1770051 reported by james beedy on 2018-05-09
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
juju
Critical
Joseph Phillips

Bug Description

bootstrapping localhost fails with "ERROR detecting credentials for "localhost" cloud provider: adding certificate "juju": Unknown request type "

see https://paste.ubuntu.com/p/x9V7dkCFwh/

$ juju --version
2.4-beta2-bionic-amd64

$ lxd.lxc --version
3.0.0

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04 LTS
Release: 18.04
Codename: bionic

Tags: lxd Edit Tag help
james beedy (jamesbeedy) on 2018-05-09
description: updated
description: updated
description: updated
Ian Booth (wallyworld) wrote :

Happened for me on a fresh bionic install.
lxd 3.0 from snap
juju from source

lxd itself is fully functional

Changed in juju:
status: New → Confirmed
importance: Undecided → Critical
milestone: none → 2.4-beta2
Changed in juju:
milestone: 2.4-beta2 → none
james beedy (jamesbeedy) on 2018-05-11
description: updated
Ian Booth (wallyworld) on 2018-05-11
Changed in juju:
milestone: none → 2.4-rc1
Vinodhini (vinu-b) wrote :

Happened to me with Xenial install when using lxd 3.0.0.
but it doesnt happen with lxd 2.21.

Vinodhini (vinu-b) wrote :

Now Iam able to see issue with lxd2.21 as well.

Ian Booth (wallyworld) wrote :

I tried installing the 2.0 snap instead

$ sudo snap install lxd --channel 2.0/stable
lxd (2.0/stable) 2.0.11 from 'canonical' installed

I run lxd init

Juju gives a different error trying to bootstrap.

---
ERROR lxdbr0 configured but no config file found at /etc/default/lxd-bridge
It looks like your lxdbr0 has not yet been configured. Please configure it via:

        sudo dpkg-reconfigure -p medium lxd

and then bootstrap again.
---

Not only does bootstrap fail, but the error message is wrong because lxd has been installed from a snap not a deb package.

tags: added: lxd
Ian Booth (wallyworld) wrote :

I have just confirmed Juju 2.3 works fine. So it's just 2.4

Ian Booth (wallyworld) wrote :

Interesting! After bootstrapping with Juju 2.3, I can now use Juju 2.4 with LXD. So Juju 2.3 gets past the step of setting up the client cert, and Juju 2.4 can then use this previously configured cert. But 2.4 fails setting up the cert if it is not there:

ERROR detecting credentials for "localhost" cloud provider: adding certificate "juju": Unknown request type

Changed in juju:
assignee: nobody → Joseph Phillips (manadart)
Changed in juju:
status: Confirmed → In Progress
Joseph Phillips (manadart) wrote :

Should be fixed under https://github.com/juju/juju/pull/8715 pending review.

Changed in juju:
status: In Progress → Fix Committed
Ryan Beisner (1chb1n) wrote :

Hi, I've confirmed that this is resolved @ edge as of today.

ubuntu@node-mees:~/openstack-on-lxd⟫ snap list
Name Version Rev Tracking Developer Notes
core 16-2.32.8 4650 stable canonical core
juju 2.4-beta3+develop-c17354d 4453 edge canonical classic

ubuntu@node-mees:~/openstack-on-lxd⟫ juju version
2.4-beta3-xenial-amd64

ubuntu@node-mees:~/openstack-on-lxd⟫ juju controllers
Use --refresh flag with this command to see the latest information.

Controller Model User Access Cloud/Region Models Machines HA Version
lxd* default admin superuser localhost/localhost 2 1 none 2.4-beta3

Anastasia (anastasia-macmood) wrote :

Marking as Fix Released as 2.4.0 is out.

Changed in juju:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers