`juju show-status-log --include-status-updates` does not show update-status history

Bug #1762600 reported by Nobuto Murata on 2018-04-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
juju
Medium
Anastasia
2.3
Medium
Anastasia

Bug Description

$ juju version
2.3.5-xenial-amd64

When I was troubleshooting LP: #1762431, I found that --include-status-updates does not work.

$ juju show-status-log -h
...
--include-status-updates (= false)
    Inlcude update status hook messages in the returned logs

$ juju show-status-log neutron-api/1 --include-status-updates=true --days 1
...
09 Apr 2018 07:12:30Z juju-unit executing running amqp-relation-changed hook
09 Apr 2018 07:12:58Z juju-unit executing running neutron-plugin-api-relation-joined hook
09 Apr 2018 07:13:23Z juju-unit executing running neutron-plugin-api-relation-changed hook
09 Apr 2018 07:13:23Z juju-unit executing running shared-db-relation-changed hook
09 Apr 2018 07:14:03Z juju-unit executing running neutron-api-relation-changed hook
09 Apr 2018 07:14:31Z juju-unit executing running neutron-plugin-api-relation-joined hook
09 Apr 2018 07:14:59Z juju-unit executing running neutron-plugin-api-relation-changed hook
09 Apr 2018 07:14:59Z juju-unit idle
09 Apr 2018 07:15:05Z juju-unit executing running identity-service-relation-changed hook
09 Apr 2018 07:15:41Z workload active Unit is ready
09 Apr 2018 07:15:43Z juju-unit idle
09 Apr 2018 07:15:49Z juju-unit executing running identity-service-relation-changed hook
09 Apr 2018 07:16:26Z juju-unit idle
09 Apr 2018 07:19:54Z juju-unit executing running identity-service-relation-changed hook
09 Apr 2018 07:20:55Z juju-unit idle
09 Apr 2018 11:57:21Z juju-unit executing running config-changed hook
09 Apr 2018 11:57:39Z workload maintenance Installing apt packages
09 Apr 2018 11:58:11Z workload active Unit is ready
09 Apr 2018 11:58:12Z juju-unit idle
09 Apr 2018 15:29:44Z juju-unit executing running config-changed hook
09 Apr 2018 15:30:02Z workload maintenance Installing apt packages
09 Apr 2018 15:30:34Z workload active Unit is ready
09 Apr 2018 15:30:35Z juju-unit idle

However, update-status hook is actually run multiple times.

$ juju debug-log -i neutron-api/1 --replay | grep 'ran "update-status" hook'
...
unit-neutron-api-1: 14:39:54 INFO juju.worker.uniter.operation ran "update-status" hook
unit-neutron-api-1: 14:44:25 INFO juju.worker.uniter.operation ran "update-status" hook
unit-neutron-api-1: 14:50:22 INFO juju.worker.uniter.operation ran "update-status" hook
unit-neutron-api-1: 14:55:18 INFO juju.worker.uniter.operation ran "update-status" hook
unit-neutron-api-1: 15:00:03 INFO juju.worker.uniter.operation ran "update-status" hook
unit-neutron-api-1: 15:05:05 INFO juju.worker.uniter.operation ran "update-status" hook
unit-neutron-api-1: 15:10:08 INFO juju.worker.uniter.operation ran "update-status" hook
unit-neutron-api-1: 15:14:29 INFO juju.worker.uniter.operation ran "update-status" hook
unit-neutron-api-1: 15:19:23 INFO juju.worker.uniter.operation ran "update-status" hook
unit-neutron-api-1: 15:24:41 INFO juju.worker.uniter.operation ran "update-status" hook
unit-neutron-api-1: 15:29:07 INFO juju.worker.uniter.operation ran "update-status" hook

Tim Penhey (thumper) wrote :

Ah... yes. The functionality was updated so the update-status hook is no longer recorded in the status-log. This is by design. It was really creating undue DB load for very little value given that it is run very regularly.

I believe the flag was left on the command to continue to work against older controllers. We should update the docs.

Changed in juju:
status: New → Invalid
Nobuto Murata (nobuto) wrote :

Understood. If you could add (deprecated) to the flag, that would be nice to avoid confusions.

$ juju show-status-log -h
...
--include-status-updates (= false)
    Inlcude update status hook messages in the returned logs (deprecated)

Changed in juju:
assignee: nobody → Anastasia (anastasia-macmood)
milestone: none → 2.4-beta1
status: Invalid → Triaged
importance: Undecided → Medium
Anastasia (anastasia-macmood) wrote :

Since the functionality has changed as a fix for bug # 1530840, we'd mark it as deprecated. As suggested, the help will say:

$ juju show-status-log -h
...
--include-status-updates (= false)
    Deprecated, has no effect for 2.3+ controllers: Include update status hook messages in the returned logs.

The prefix makes it a bit more obvious - there is a strong evidence that many users do not read the sentence to the end :) I will also fix the typo in 'Include' \o/... This flag had no effect since 2.3-rc2. I'll also make a note in the code to remove this flag altogether in next major release.

John A Meinel (jameinel) wrote :
Changed in juju:
status: Triaged → Fix Committed
Changed in juju:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers