ERROR secret key for user "<username>" not found

Bug #1751849 reported by james beedy on 2018-02-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
juju
Medium
John A Meinel
2.3
Medium
Anastasia

Bug Description

A user tries to register and gets:

$ juju register <mylonghash>
Enter a new password:
Confirm password:
Enter a name for this controller: pdl-aws
Controller "pdl-aws" already exists.
Enter a name for this controller: pdl-aws-1
ERROR secret key for user "myuser" not found

controller: 2.3.3
client: 2.3.3-highsierra-amd64

james beedy (jamesbeedy) on 2018-02-26
description: updated
Anastasia (anastasia-macmood) wrote :

@james beedy (jamesbeedy),

We have difficulties reproducing this on our side. Any chance, you can provide more information, repro steps?

For example, what did you use to bootstrap and add user?...

Changed in juju:
status: New → Incomplete
james beedy (jamesbeedy) wrote :

@anastasia-macmood I'm having a hard time repro on this too

the operations preformed were:

juju add-user myuser

juju grant myuser superuser

juju grant myuser admin mymodel

Following ^, had the user try to run the register command and the error showed.

Possibly we could target better user facing messaging in this scenario then "ERROR secret key for user "myuser" not found"? Should I file another bug for better user facing messaging, or do you want to use this one?

thx

Anastasia (anastasia-macmood) wrote :

@james beedy,

The token used in register command is a one-time-only token. If it was already used on this client or another client, it will be invalid and a user will need to be re-issued a new token.

This message will only happen if (1) this user has not been issued a register token before or (2) the user already tried to register.

The only way to make the message more user-friendly is to say something along the lines of "if you believe that you should be able to register now, please get a new registration token and try again" :D

I would really appreciate if you could provide a sample of this wording. Would be great to know what you would have found useful in this situation \o/

Maybe something like:

this token appears to have expired

this token has already been consumed

This token appears to be invalid, it might have expired or already been
used.

On Tue, Feb 27, 2018 at 7:34 AM, Anastasia <email address hidden>
wrote:

> @james beedy,
>
> The token used in register command is a one-time-only token. If it was
> already used on this client or another client, it will be invalid and a
> user will need to be re-issued a new token.
>
> This message will only happen if (1) this user has not been issued a
> register token before or (2) the user already tried to register.
>
> The only way to make the message more user-friendly is to say something
> along the lines of "if you believe that you should be able to register
> now, please get a new registration token and try again" :D
>
> I would really appreciate if you could provide a sample of this wording.
> Would be great to know what you would have found useful in this
> situation \o/
>
> --
> You received this bug notification because you are subscribed to juju.
> Matching subscriptions: juju bugs
> https://bugs.launchpad.net/bugs/1751849
>
> Title:
> ERROR secret key for user "<username>" not found
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/juju/+bug/1751849/+subscriptions
>

james beedy (jamesbeedy) wrote :

@anastasia-macmood anything to point the user to the next step, instead of an error that implies it’s broken/the end of the road. What you have suggested would work great. Thanks

Changed in juju:
status: Incomplete → Triaged
importance: Undecided → Medium
tags: added: usability
Changed in juju:
status: Triaged → In Progress
assignee: nobody → Anastasia (anastasia-macmood)
Anastasia (anastasia-macmood) wrote :
Changed in juju:
milestone: none → 2.4-beta1
John A Meinel (jameinel) wrote :
John A Meinel (jameinel) on 2018-02-28
Changed in juju:
status: In Progress → Fix Committed
Anastasia (anastasia-macmood) wrote :

Landed in develop (2.4+) as part of a larger merge : https://github.com/juju/juju/pull/8437

Changed in juju:
assignee: Anastasia (anastasia-macmood) → John A Meinel (jameinel)
Changed in juju:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers