intermittent unit failure: worker_test.go:231: WorkerSuite.TestTransportTimeout

Bug #1749081 reported by Anastasia on 2018-02-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
juju
Medium
Joseph Phillips
Changed in juju:
assignee: nobody → Joseph Phillips (manadart)
status: Triaged → In Progress
Joseph Phillips (manadart) wrote :

The worker is started with a millisecond timeout, with the assumption that it is up before the connection attempt. Sometimes it is not.

Simple to reproduce consistently - just wind out the timeout and it fails every time with the message observed in the CI failure.

Joseph Phillips (manadart) wrote :

Changing the timeout to a nanosecond is likely sufficient, but I also added a retry loop just to make sure.

https://github.com/juju/juju/pull/8378

if you can add a time.Sleep(time.Millisecond) somewhere and a test breaks,
then its likely to break in CI at some point.

I'm ok with the change as proposed, but it might actually be better to
force something about the connection to be slow on the other side.

John
=:->

On Feb 14, 2018 7:50 PM, "Joseph Phillips" <email address hidden>
wrote:

> Changing the timeout to a nanosecond is likely sufficient, but I also
> added a retry loop just to make sure.
>
> https://github.com/juju/juju/pull/8378
>
> --
> You received this bug notification because you are subscribed to juju.
> Matching subscriptions: juju bugs
> https://bugs.launchpad.net/bugs/1749081
>
> Title:
> intermittent unit failure: worker_test.go:231:
> WorkerSuite.TestTransportTimeout
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/juju/+bug/1749081/+subscriptions
>

Joseph Phillips (manadart) wrote :

Pushed up a change as suggested.
Connection should now be guaranteed to time out.

Changed in juju:
status: In Progress → Fix Committed
John A Meinel (jameinel) on 2018-02-19
Changed in juju:
milestone: none → 2.3.4
milestone: 2.3.4 → 2.4-beta1
Changed in juju:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers