Can't deploy bundle when existing model has subordinates without relations

Bug #1736592 reported by Casey Marshall
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
juju
High
Tim Penhey

Bug Description

Juju 2.3-rc2-xenial-amd64 installed from candidate snap, using manual provider (which is why I really need map-machines=existing...).

When I try to deploy a bundle with --map-machines=existing, I get:

+ juju deploy ./bundle.yaml --map-machines=existing
ERROR cannot deploy bundle: getting application constraints: constraints do not apply to subordinate applications

The bundle contains several applications, relating them to telegraf:

series: xenial
services:
  haproxy:
...
  telegraf:
    charm: "./charms/telegraf"
    series: xenial
    expose: true
relations:
  - [livepatch-health, haproxy]
  - ["livepatch-health:database", "postgresql:db"]
  - ["telegraf:postgresql", "postgresql:db-admin"]
  - ["telegraf:juju-info", "postgresql:juju-info"]
  - ["telegraf:juju-info", "livepatch-health:juju-info"]
  - [livepatch-health, "prometheus:target"]
machines:
  "0":

Revision history for this message
Casey Marshall (cmars) wrote :

Controller info:

ubuntu@deployer:~/livepatch$ juju controllers
Use --refresh flag with this command to see the latest information.

Controller Model User Access Cloud/Region Models Machines HA Version
manual* default admin superuser manual 2 1 none 2.2.6

Tim Penhey (thumper)
Changed in juju:
status: New → Triaged
importance: Undecided → High
milestone: none → 2.3.1
Revision history for this message
Tim Penhey (thumper) wrote :

This works on a 2.3 controller. But it seems to be a problem against older controllers.

We'll look to get this fixed asap.

summary: - Can't deploy bundle with map-machines=existing and subordinates
+ Can't deploy bundle when existing model has subordinates on controller
+ <= 2.2.6
Changed in juju:
milestone: 2.3.1 → none
Tim Penhey (thumper)
Changed in juju:
milestone: none → 2.3.2
Tim Penhey (thumper)
summary: - Can't deploy bundle when existing model has subordinates on controller
- <= 2.2.6
+ Can't deploy bundle when existing model has subordinates without
+ relations
Changed in juju:
assignee: nobody → Tim Penhey (thumper)
status: Triaged → In Progress
Revision history for this message
Tim Penhey (thumper) wrote :
Revision history for this message
Andrew McLeod (admcleod) wrote :

confirmed with controller and juju version 2.3.1 (2.3.1-xenial-s390x)

Revision history for this message
Pablo Hörtner (redtux2000) wrote :

I am still experiencing this problem on Xenial with most recent Juju and LXD versions.

$ juju deploy cs:~charmers/bundle/web-infrastructure-in-a-box
Located bundle "cs:~charmers/bundle/web-infrastructure-in-a-box-10"
ERROR cannot deploy bundle: getting application constraints: constraints do not apply to subordinate applications

$ lsb_release -d
Description: Ubuntu 16.04.3 LTS

$ uname -r
4.4.0-104-generic

$ juju version
2.3.1-xenial-amd64

$ lxc version
2.21

$ juju controllers --refresh
Controller Model User Access Cloud/Region Models Machines HA Version
lxd* default admin superuser localhost/localhost 3 26 3 2.2.6

$ lxc profile list
+-----------------------------------+---------+
| NAME | USED BY |
+-----------------------------------+---------+
| default | 33 |
+-----------------------------------+---------+
| juju-conjure-openstack-novalx-f75 | 16 |
+-----------------------------------+---------+
| juju-controller | 5 |
+-----------------------------------+---------+
| juju-default | 4 |
+-----------------------------------+---------+
| maas | 1 |
+-----------------------------------+---------+

Tim Penhey (thumper)
Changed in juju:
status: In Progress → Fix Committed
Alvaro Uria (aluria)
tags: added: canonical-bootstack
Changed in juju:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers