cinder provider fails to detach/remove if volume doesn't exist

Bug #1733756 reported by Andrew Wilkins on 2017-11-22
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
juju
High
Andrew Wilkins
2.3
High
Andrew Wilkins

Bug Description

If you create cinder storage for a charm, then remove the Cinder volume directly, then Juju will be unable to remove the volume entity. This is due to a bug in the Goose client, which misinterprets a 404 as lack of API support.

The status on the volume, as output by "juju storage --volume":

... detaching listing volume attachments: the server does not support listing attached volumes
caused by: Resource at http://<redacted>/v2/<redacted>/servers/<redacted>/os-volume_attachments not found
caused by: request (http://<redacted>/v2/<redacted>/servers/<redacted>/os-volume_attachments) returned unexpected status: 404; error info: {"itemNotFound": {"message": "The resource could not be found.", "code": 404}}

Tim Penhey (thumper) on 2017-11-22
Changed in juju:
milestone: 2.4-beta1 → 2.3.1
Changed in juju:
milestone: 2.3.1 → none
Tim Penhey (thumper) on 2017-12-10
Changed in juju:
milestone: none → 2.3.2
Andrew Wilkins (axwalk) on 2017-12-11
Changed in juju:
status: Triaged → In Progress
assignee: nobody → Andrew Wilkins (axwalk)
Andrew Wilkins (axwalk) wrote :

As is usual, the issue turns out to be a little more complicated. Goose is morphing some not-found errors in the nova API, and the cinder API is not using goose's errors at all (so the methods of determining whether an error is due to "not found" don't work). Will work on updating the cinder API to use them.

Andrew Wilkins (axwalk) on 2017-12-13
Changed in juju:
milestone: 2.3.2 → 2.4-beta1
status: In Progress → Triaged
Anastasia (anastasia-macmood) wrote :

This change would have been brought over to develop (2.4-b1) in one of the regular merges from 2.3 branch.

Changed in juju:
status: Triaged → Fix Committed
Changed in juju:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers