Pointer to docs for bootstrap process per cloud

Bug #1624677 reported by Mark Shuttleworth on 2016-09-17
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
juju
Medium
Unassigned

Bug Description

The bootstrap process is much improved in 2.0 but there is still conceptual friction when people are unsure of exactly what information is required for each step in the interactive process. We could address that up front by pointing folks at the right doc URL. For example:

  $ juju bootstrap new-controller aws/us-west-2
  Detailed guide at https://jujucharms.com/docs/bootstrap/aws/
  ERROR detecting credentials for "aws" cloud provider
  AWS_SECRET_ACCESS_KEY not found in environment

Of course it would be better to provide a walk through interactive bootstrap than the error above, but I think the most important thing is to provide the URL for guidance, for each cloud or type of cloud.

TO be clear, the "Guide" line pointing to the relevant docs should be
there even if the credentials are detected and interactive bootstrap
proceeds as normal. The aim is to have the URL available as a guideline
for each of the interactive bootstrap steps, if needed.

Anastasia (anastasia-macmood) wrote :

Great idea \o/

I have also added a documentation issue to have per-cloud pages created - https://github.com/juju/docs/issues/1378

Changed in juju:
status: New → Triaged
importance: Undecided → Medium
tags: added: usability
Richard Harding (rharding) wrote :

Marking #1625770 as a dupe of this as it's close to the same idea. Helping the user get onto the path of adding their credentials clearly.

Peter Matulis (petermatulis) wrote :

From the documentation side, individual cloud pages are listed on the clouds landing page:

https://docs.jujucharms.com/devel/clouds

So for, say, GCE, the `bootstrap` command could reference this page:

https://docs.jujucharms.com/devel/clouds-gce

If we want versioning then the software would need to construct the URL accordingly. For 2.5:

https://docs.jujucharms.com/2.5/clouds-gce

If there is an upcoming domain name change then we should wait until that is settled. We should avoid exposing old domain names, even with redirects in place.

Since 'juju bootstrap' is now interactive and there is a lot of information both on jujucharms and discourse, I'd mark this report as Fix Released.

Changed in juju:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.