bootstrap failure with MAAS doesn't tell me which node has a problem

Bug #1591379 reported by Jason Hobbs on 2016-06-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
juju
Medium
Unassigned

Bug Description

I tried to bootstrap with juju2 and maas2, and got this failure:

ubuntu@juju-test:~/openstack-base$ juju bootstrap vpil-maas-controller vpil-maas
Creating Juju controller "local.vpil-maas-controller" on vpil-maas
Bootstrapping model "controller"
Starting new instance for initial controller
Launching instance
WARNING no architecture was specified, acquiring an arbitrary node
ERROR failed to bootstrap model: cannot start bootstrap instance: unexpected: ServerError: 400 BAD REQUEST ({"storage": ["Mount the root '/' filesystem to be able to deploy this node."]})

It doesn't tell me which node it tried to boot strap on, so I don't know which one I need to go look at to fix.

Changed in juju-core:
status: New → Triaged
tags: added: maas-provider usability
Changed in juju-core:
importance: Undecided → Medium
tags: added: papercut
tags: added: oil-2.0
tags: added: bitesize
Changed in juju-core:
milestone: none → 2.0.0
affects: juju-core → juju
Changed in juju:
milestone: 2.0.0 → none
milestone: none → 2.0.0
Curtis Hovey (sinzui) on 2016-10-06
Changed in juju:
milestone: 2.0.0 → 2.0.1
Curtis Hovey (sinzui) on 2016-11-01
Changed in juju:
milestone: 2.0.1 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers