"juju create-backup" fails if you're not operating on the admin model

Bug #1576184 reported by Graham Morrison on 2016-04-28
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
juju
Medium
Heather Lanigan

Bug Description

"juju create-backup" will fail if you're not operating on the admin model:

    $ juju create-backup
    ERROR backups are not supported for hosted models

Since create-backup operates only on admin, it doesn't make much sense to require you to be operating on a specific model.

(Similar to #1563705)

Changed in juju-core:
status: New → Triaged
importance: Undecided → Medium
tags: added: ensure-availability juju-release-support
Nick Veitch (evilnick) on 2016-04-28
tags: added: docteam
Eric Snow (ericsnowcurrently) wrote :

The problem is that implicitly always using the admin model would mean that any future attempt to support per-model backups would be problematic, perhaps even backward-incompatible. We'd probably have to add another command, e.g. "juju create-model-backup", which is inconsistent with all the other commands. "juju create-backup" is more correct, so I think that the current behavior, with the clear error message, is appropriate.

That said, other than using the admin model implicitly, do you think there is something "juju create-backup" could do differently for a better user experience?

Nick Veitch (evilnick) wrote :

I don't think the error message is that clear tbh. Would probably make more sense if it said
 "ERROR backups are only supported from the admin model"
while that is still the case.

Graham Morrison (morrisong) wrote :

I agree with Nick. I think the problem is that the error message implies a backup isn't possible. Yet if you switch or specify admin specifically, it is possible. I think an extra hint in the output would be helpful.

tags: added: usability
Changed in juju-core:
milestone: none → 2.0.0
affects: juju-core → juju
Changed in juju:
milestone: 2.0.0 → none
milestone: none → 2.0.0
Curtis Hovey (sinzui) on 2016-10-06
Changed in juju:
milestone: 2.0.0 → 2.0.1
Curtis Hovey (sinzui) on 2016-11-01
Changed in juju:
milestone: 2.0.1 → none
Changed in juju:
assignee: nobody → Heather Lanigan (hmlanigan)
status: Triaged → In Progress
milestone: none → 2.4-beta1
Heather Lanigan (hmlanigan) wrote :

The error message is still confusing people. Updating it to the suggestion:
https://github.com/juju/juju/pull/8264

Changed in juju:
status: In Progress → Fix Committed
Changed in juju:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers