Backport OpenStack provider to 0.5 series

Reported by Clint Byrum on 2012-09-10
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pyjuju
Undecided
Unassigned
0.5
Wishlist
Clint Byrum
juju (Ubuntu)
Undecided
Unassigned
Precise
High
Unassigned

Bug Description

== SRU Information ==

Note that this is not a bug fix bug a backported API enablement fix. Without this change, HPCloud and others cannot be used with juju in precise.

[Test Case]
1. Obtain credentials for an OpenStack cloud (HPCloud or a private instance of OpenStack)
2. Setup your credentials in ~/.juju/environments.yaml - Here is a redacted sample for hpcloud:

  hpcloud:
    juju-origin: proposed
    access-key: XXXXXXXXXXXXXXXXXXXX
    secret-key: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    project-id: "<email address hidden>"
    admin-secret: ffffffffffffffffffffffffffffffff
    control-bucket: juju-eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee
    default-image-id: 8419
    default-instance-type: standard.small
    default-series: precise
    region: az-1.region-a.geo-1
    nova-uri: https://region-a.geo-1.identity.hpcloudsvc.com:35357/v2.0/
    auth-url: https://region-a.geo-1.identity.hpcloudsvc.com:35357/v2.0/
    auth-mode: userpass
    username: <email address hidden>
    password: ZZZZZZZZ
    project-name: <email address hidden>
    type: openstack

3. deploy mysql

juju bootstrap -e hpcloud
juju deploy mysql -e hpcloud

4. Verify it works

juju ssh -e hpcloud mysql/0 'sudo mysql -uroot -p`cat /var/lib/juju/mysql.passwd`'

[Regression Potential]
This is entirely new code, so the risk of regression is very low. One issue may be that entries of type: openstack added to environments.yaml will cause errors on earlier versions of juju, but these can be easily commented out.

==

The OpenStack provider is fairly isolated from the rest of the code base in Juju, and enables access to additional cloud providers (Namely, HP).

Related branches

Changed in juju:
status: New → Fix Released
Changed in juju (Ubuntu):
status: New → Fix Released
Changed in juju (Ubuntu Precise):
status: New → Triaged
importance: Undecided → High
description: updated

Default instance type is obsolete in config, proper constraints
supports exist in openstack provider

Sent from my iPad

On Sep 27, 2012, at 3:11 PM, Clint Byrum <email address hidden> wrote:

> ** Description changed:
>
> + == SRU Information ==
> +
> + Note that this is not a bug fix bug a backported API enablement fix.
> + Without this change, HPCloud and others cannot be used with juju in
> + precise.
> +
> + [Test Case]
> + 1. Obtain credentials for an OpenStack cloud (HPCloud or a private instance of OpenStack)
> + 2. Setup your credentials in ~/.juju/environments.yaml - Here is a redacted sample for hpcloud:
> +
> + hpcloud:
> + juju-origin: proposed
> + access-key: XXXXXXXXXXXXXXXXXXXX
> + secret-key: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
> + project-id: "<email address hidden>"
> + admin-secret: ffffffffffffffffffffffffffffffff
> + control-bucket: juju-eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee
> + default-image-id: 8419
> + default-instance-type: standard.small
> + default-series: precise
> + region: az-1.region-a.geo-1
> + nova-uri: https://region-a.geo-1.identity.hpcloudsvc.com:35357/v2.0/
> + auth-url: https://region-a.geo-1.identity.hpcloudsvc.com:35357/v2.0/
> + auth-mode: userpass
> + username: <email address hidden>
> + password: ZZZZZZZZ
> + project-name: <email address hidden>
> + type: openstack
> +
> + 3. deploy mysql
> +
> + juju bootstrap -e hpcloud
> + juju deploy mysql -e hpcloud
> +
> + 4. Verify it works
> +
> + juju ssh -e hpcloud mysql/0 'sudo mysql -uroot -p`cat
> + /var/lib/juju/mysql.passwd`'
> +
> + [Regression Potential]
> + This is entirely new code, so the risk of regression is very low. One issue may be that entries of type: openstack added to environments.yaml will cause errors on earlier versions of juju, but these can be easily commented out.
> +
> + ==
> +
> The OpenStack provider is fairly isolated from the rest of the code base
> in Juju, and enables access to additional cloud providers (Namely, HP).
>
> --
> You received this bug notification because you are subscribed to juju.
> https://bugs.launchpad.net/bugs/1048533
>
> Title:
> Backport OpenStack provider to 0.5 series
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/juju/+bug/1048533/+subscriptions

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers