Bundle Export link broken in Juju-Gui 16+

Bug #1413654 reported by Charles Butler
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
juju-gui
Fix Released
High
Jeff Pihach

Bug Description

When attempting to export a bundle from Juju GUI charm version 16 and 17 - the export bundles link does nothing. Upon further investigation it appears there is a missing variable in models.js

Attaching a screenshot with the stack trace.

Revision history for this message
Charles Butler (lazypower) wrote :
Revision history for this message
Charles Butler (lazypower) wrote :

I was able to get the bundle to export after fully dumping cache and reloading the page. Not sure if related to stale local cache or if this is a byproduct of using the gui for a while and something goes awry.

This might be difficult to reproduce.

Changed in juju-gui:
status: New → Triaged
importance: Undecided → High
Jeff Pihach (hatch)
Changed in juju-gui:
assignee: nobody → Jeff Pihach (hatch)
status: Triaged → Fix Released
Revision history for this message
Ryan Beisner (1chb1n) wrote :

This issue still exists with cs:trusty/juju-gui-21.

I've cleared cache on 3 browsers: google chrome, chromium, firefox. Clicking the "Export" link simply does nothing. I've attached a screenshot of the browser's js trace.

<snip>
2015-03-17 02:24:23 [DEBUG] deployer.charm: Retrieving store charm cs:trusty/juju-gui-21
<snip>

Revision history for this message
Richard Harding (rharding) wrote :

This looks like a bug around placement in the export. I'm going to open a new bug to track that work as it's a different line of work.

Revision history for this message
Ryan Beisner (1chb1n) wrote :

Juju stat for my deployed bundle: http://paste.ubuntu.com/10615355/

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers