The local_test target fails on focal

Bug #1893167 reported by Barry Price
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
juju-deployer
Medium
Unassigned

Bug Description

On an amd64 machine running the latest focal (20.04) LTS, the local_test target fails:

https://paste.ubuntu.com/p/b98Cym3dCX/

If I apply the patch for LP:1893163, it will also test with Python 3.8, but that too fails:

https://paste.ubuntu.com/p/dSbKjRgVvJ/

Related branches

Tom Haddon (mthaddon)
Changed in juju-deployer:
status: New → Fix Released
Revision history for this message
Barry Price (barryprice) wrote :

Still seeing one failure here.

To reproduce, launch a Focal VM, e.g.

$ multipass launch focal -n jujutest
$ multipass shell jujutest

Then within the VM, install dependencies (LP:1893162):

ubuntu@jujutest:~$ sudo apt install brz make tox

Install Juju itself:

ubuntu@jujutest:~$ sudo snap install juju --classic

Clone the latest source, and attempt to run the tests:

ubuntu@jujutest:~$ bzr clone lp:juju-deployer
ubuntu@jujutest:~$ cd juju-deployer
ubuntu@jujutest:~$ make local_test

Here's the output I see:

https://paste.ubuntu.com/p/TQvqYSczSW/

I've submitted another MP, linked, to resolve the YAMLLoadWarning, but that's not the root cause.

Barry Price (barryprice)
Changed in juju-deployer:
status: Fix Released → New
Tom Haddon (mthaddon)
Changed in juju-deployer:
importance: Undecided → Medium
status: New → Confirmed
Barry Price (barryprice)
Changed in juju-deployer:
assignee: nobody → Barry Price (barryprice)
status: Confirmed → In Progress
Barry Price (barryprice)
Changed in juju-deployer:
status: In Progress → Fix Committed
assignee: Barry Price (barryprice) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers