xenial lxc containers not starting

Bug #1568150 reported by Matt Rae on 2016-04-08
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
cloud-init
High
Unassigned
juju-core
Undecided
Unassigned
cloud-init (Ubuntu)
High
Unassigned

Bug Description

When deploying a xenial lxc container to a xenial host, the container fails during cloud-init with the following error in the container's /var/log/cloud-init-output.log:

2016-04-08 21:07:05,190 - util.py[WARNING]: failed of stage init-local
failed run of stage init-local
------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/bin/cloud-init", line 515, in status_wrapper
    ret = functor(name, args)
  File "/usr/bin/cloud-init", line 250, in main_init
    init.fetch(existing=existing)
  File "/usr/lib/python3/dist-packages/cloudinit/stages.py", line 318, in fetch
    return self._get_data_source(existing=existing)
  File "/usr/lib/python3/dist-packages/cloudinit/stages.py", line 227, in _get_data_source
    ds.check_instance_id(self.cfg)):
  File "/usr/lib/python3/dist-packages/cloudinit/sources/DataSourceNoCloud.py", line 220, in check_instance_id
    dirs=self.seed_dirs)
AttributeError: 'DataSourceNoCloudNet' object has no attribute 'seed_dirs'

Trusty containers start just fine.

Using juju 1.25.5 and MAAS 1.9.2

Commands to reproduce:

juju bootstrap --constraints "tags=juju" --upload-tools --show-log --debug
juju set-constraints "tags="
juju add-machine --series xenial
juju deploy --to lxc:1 local:xenial/ubuntu ubuntu

Related branches

Matt Rae (mattrae) wrote :
Cheryl Jennings (cherylj) wrote :

Looks like a cloud-init bug. Targeting to cloud-init for their review.

Changed in juju-core:
status: New → Incomplete
Matt Rae (mattrae) on 2016-04-11
tags: added: cpec
Serge Hallyn (serge-hallyn) wrote :

I see this error msg in uvt-kvm vms. However the vm boots fine, I just get that error msg.

Scott Moser (smoser) on 2016-04-13
Changed in cloud-init:
importance: Undecided → High
status: New → Confirmed
Scott Moser (smoser) on 2016-04-13
Changed in cloud-init (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in cloud-init:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cloud-init - 0.7.7~bzr1208-0ubuntu1

---------------
cloud-init (0.7.7~bzr1208-0ubuntu1) xenial; urgency=medium

  * New upstream snapshot.
    - phone_home: allow usage of fqdn (LP: #1566824) [Ollie Armstrong]
    - chef: straighten out validation_cert and validation_key (LP: #1568940)
    - skip bridges when generating fallback networking (LP: #1569974)
    - rh_subscription: only check subscription if configured (LP: #1536706)
    - SmartOS, CloudSigma: fix error when dmi data is not availble
      (LP: #1569469)
    - DataSourceNoCloud: fix check_instance_id when upgraded (LP: #1568150)
    - lxd: adds basic support for dpkg based lxd-bridge
      configuration. (LP: #1569018)
    - centos: Ensure that a resolve conf object is written as a string.
      (LP: #1479988)

 -- Scott Moser <email address hidden> Wed, 13 Apr 2016 13:19:03 -0400

Changed in cloud-init (Ubuntu):
status: Confirmed → Fix Released
Anastasia (anastasia-macmood) wrote :

With fix in cloud-init, is this failure still occurring?

Changed in juju-core:
status: Incomplete → Won't Fix
status: Won't Fix → Invalid
Scott Moser (smoser) wrote :

This is fixed in cloud-init 0.7.7

Changed in cloud-init:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers