Please switch dependency from gopkg.in/yaml.v1 to gopkg.in/yaml.v2

Bug #1504821 reported by James Page on 2015-10-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
juju-core
High
Martin Packman

Bug Description

Whilst reviewing dependencies for MIR bug 1267393 for juju-core in Ubuntu, we've noticed that the dependency chain depends on yaml.v1 which in turn depends on an older version of gocheck.

Please update to yaml.v2 which depends on the newer check.v1 package (which is used by other dependencies within the juju-core dep chain).

Changed in juju-core:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Martin Packman (gz)
Martin Packman (gz) wrote :

A couple more:

https://github.com/juju/httprequest/pull/35
https://github.com/natefinch/lumberjack/pull/14

When those land, can do charmstore and charmrepo (which are mutually dependent), then finally juju itself.

Matthew Williams (mattyw) wrote :

I've added a PR to address this in core: http://reviews.vapour.ws/r/2883/

Changed in juju-core:
status: In Progress → Fix Committed
Changed in juju-core:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers