Deadlock in login tests

Bug #1347939 reported by Dave Cheney on 2014-07-23
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
juju-core
High
Ian Booth
1.20
Critical
Ian Booth

Bug Description

The session copying fix triggers a deadlock in apiserver tests (login test) > 50% of the time. Fixing the deadlock will solve the problem.

Ian Booth (wallyworld) wrote :

I found an unrelated deadlock in the login tests. It's very much timing related so it is plausible that underlying changes to state may lead to the deadlock occurring more frequently.

The problematic test is TestLoginRateLimited on loginSuite. This starts N login attempts, and then starts attempt N+1. The expectation in that N+1 will error out immediately with a try again error. But, all N+1 login attempts are racing via the rpc layer to reach the login on the server. And attempt N+1 may beat one of the N attempts to get there, thus one of the N attempts is the one to get the retry error. This stuff up the tests because attempt N+1 now blocks and the code to unblock the pending login attempts is never run.

tags: added: test-failure
summary: - build is unstable since 7524c62
+ Deadlock in login tests
description: updated
Changed in juju-core:
assignee: nobody → Ian Booth (wallyworld)
Andrew Wilkins (axwalk) wrote :

I've marked the older lp:1323357 as a duplicate of this, as there's some more analysis and activity here.

Changed in juju-core:
status: Confirmed → In Progress
Ian Booth (wallyworld) on 2014-07-24
Changed in juju-core:
status: In Progress → Fix Committed
Curtis Hovey (sinzui) on 2014-08-21
Changed in juju-core:
importance: Critical → High
Curtis Hovey (sinzui) on 2014-09-08
Changed in juju-core:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers