DesiredVersion should not return versions newer than API Server

Bug #1304340 reported by John A Meinel on 2014-04-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
juju-core
High
John A Meinel

Bug Description

When the API server notices that desired Agent Version has changed, but version.Current is older, it could not indicate to the callers that they should upgrade.

Related branches

John A Meinel (jameinel) wrote :

Note that the API server shouldn't restrict the version for agents that run the API server, but *should* for all the other instances.

John A Meinel (jameinel) on 2014-04-08
Changed in juju-core:
milestone: 1.19.1 → 2.0
status: Triaged → In Progress
Go Bot (go-bot) on 2014-04-09
Changed in juju-core:
status: In Progress → Fix Committed
Curtis Hovey (sinzui) on 2014-04-11
Changed in juju-core:
milestone: 2.0 → 1.19.0
Curtis Hovey (sinzui) on 2014-04-15
Changed in juju-core:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers