hook failures - nil pointer dereference

Bug #1303787 reported by Tim Van Steenburgh on 2014-04-07
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
juju-core
Medium
Dave Cheney

Bug Description

I deployed the following on wolfe-01 (ppc64el) using the local provider:

The charms used:

  parent branch: bzr+ssh://bazaar.launchpad.net/~charmers/charms/precise/haproxy/trunk/
  parent branch: bzr+ssh://bazaar.launchpad.net/~charmers/charms/precise/memcached/trunk/
  parent branch: bzr+ssh://bazaar.launchpad.net/~mbruzek/charms/trusty/mysql/apache2fix/
  parent branch: bzr+ssh://bazaar.launchpad.net/~cabs-team/charms/trusty/sugarcrm/trunk/

The deploy script:

juju deploy local:trusty/sugarcrm
juju deploy local:trusty/mysql
juju deploy local:trusty/memcached
juju deploy local:trusty/haproxy
juju set mysql dataset-size="1G"
juju add-relation sugarcrm mysql
juju add-relation sugarcrm memcached
juju add-relation sugarcrm haproxy
juju expose haproxy

I waited for all services to start up successfully, and they did.

Fast-forward 7 hours, I log in to wolfe-01 and this is the juju status:
http://paste.ubuntu.com/7216852/

I've attached the all-machines.log, which contains nil pointer errors.

Unfortunately, I can't be sure what transpired on the machine during those 7 hours - only that I didn't touch anything.

Curtis Hovey (sinzui) on 2014-04-07
tags: added: hooks ppc64el
Changed in juju-core:
status: New → Triaged
importance: Undecided → High
milestone: none → 1.19.0
tags: added: local-provider
Kapil Thangavelu (hazmat) wrote :

this is not local provider.. this is client panic/failure on ppc.

Andrew Wilkins (axwalk) wrote :

Looks like the local provider to me, from the log.

Tim: any obvious issues with OOM or disk space?

Kapil Thangavelu (hazmat) wrote :

it is the local provider, but its totally unrelated to this being local provider.. this is just a flat out ppc issue with the websocket code afaics.

There's lots of free disk (94G). I can't be sure about RAM since I didn't check that at the time, but I think OOM would have been unlikely since there was 24G allocated to wolfe-01 at the time.

Dave Cheney (dave-cheney) wrote :

Hi Tim,

all-machines.log has been corrupted by rsync, can you please, and in the future, include the machine-0.log file which represents the provision er and the API server.

I can see you are building from source and using --upload-tools

Can you please tell me the revision you are building from and the version of gccgo-4.9 and gccgo-go you are using.

Thanks

Dave

not rsync, rsyslog.

On Tue, Apr 8, 2014 at 9:22 AM, Dave Cheney <email address hidden> wrote:
> Hi Tim,
>
> all-machines.log has been corrupted by rsync, can you please, and in the
> future, include the machine-0.log file which represents the provision er
> and the API server.
>
> I can see you are building from source and using --upload-tools
>
> Can you please tell me the revision you are building from and the
> version of gccgo-4.9 and gccgo-go you are using.
>
> Thanks
>
> Dave
>
> --
> You received this bug notification because you are subscribed to juju-
> core.
> Matching subscriptions: MOAR JUJU SPAM!
> https://bugs.launchpad.net/bugs/1303787
>
> Title:
> hook failures - nil pointer dereference
>
> Status in juju-core:
> Triaged
>
> Bug description:
> I deployed the following on wolfe-01 (ppc64el) using the local
> provider:
>
> The charms used:
>
> parent branch: bzr+ssh://bazaar.launchpad.net/~charmers/charms/precise/haproxy/trunk/
> parent branch: bzr+ssh://bazaar.launchpad.net/~charmers/charms/precise/memcached/trunk/
> parent branch: bzr+ssh://bazaar.launchpad.net/~mbruzek/charms/trusty/mysql/apache2fix/
> parent branch: bzr+ssh://bazaar.launchpad.net/~cabs-team/charms/trusty/sugarcrm/trunk/
>
> The deploy script:
>
> juju deploy local:trusty/sugarcrm
> juju deploy local:trusty/mysql
> juju deploy local:trusty/memcached
> juju deploy local:trusty/haproxy
> juju set mysql dataset-size="1G"
> juju add-relation sugarcrm mysql
> juju add-relation sugarcrm memcached
> juju add-relation sugarcrm haproxy
> juju expose haproxy
>
> I waited for all services to start up successfully, and they did.
>
> Fast-forward 7 hours, I log in to wolfe-01 and this is the juju status:
> http://paste.ubuntu.com/7216852/
>
> I've attached the all-machines.log, which contains nil pointer errors.
>
> Unfortunately, I can't be sure what transpired on the machine during
> those 7 hours - only that I didn't touch anything.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/juju-core/+bug/1303787/+subscriptions

Ugh, sorry Dave, but since the original bug report, juju has been upgraded on wolfe-01 to 1.18. I don't know what the original versions were, except that juju was 1.17.7.

Dave Cheney (dave-cheney) wrote :

Marking as incomplete, need more information.

Changed in juju-core:
assignee: nobody → Dave Cheney (dave-cheney)
status: Triaged → Incomplete
Dave Cheney (dave-cheney) wrote :

Sure, can you please provide the rest of the information. I'd be
surprised if 1.17 -> 1.18 had any impact on the frequency of this bug.

On Tue, Apr 8, 2014 at 10:00 AM, Tim Van Steenburgh
<email address hidden> wrote:
> Ugh, sorry Dave, but since the original bug report, juju has been
> upgraded on wolfe-01 to 1.18. I don't know what the original versions
> were, except that juju was 1.17.7.
>
> --
> You received this bug notification because you are subscribed to juju-
> core.
> Matching subscriptions: MOAR JUJU SPAM!
> https://bugs.launchpad.net/bugs/1303787
>
> Title:
> hook failures - nil pointer dereference
>
> Status in juju-core:
> Incomplete
>
> Bug description:
> I deployed the following on wolfe-01 (ppc64el) using the local
> provider:
>
> The charms used:
>
> parent branch: bzr+ssh://bazaar.launchpad.net/~charmers/charms/precise/haproxy/trunk/
> parent branch: bzr+ssh://bazaar.launchpad.net/~charmers/charms/precise/memcached/trunk/
> parent branch: bzr+ssh://bazaar.launchpad.net/~mbruzek/charms/trusty/mysql/apache2fix/
> parent branch: bzr+ssh://bazaar.launchpad.net/~cabs-team/charms/trusty/sugarcrm/trunk/
>
> The deploy script:
>
> juju deploy local:trusty/sugarcrm
> juju deploy local:trusty/mysql
> juju deploy local:trusty/memcached
> juju deploy local:trusty/haproxy
> juju set mysql dataset-size="1G"
> juju add-relation sugarcrm mysql
> juju add-relation sugarcrm memcached
> juju add-relation sugarcrm haproxy
> juju expose haproxy
>
> I waited for all services to start up successfully, and they did.
>
> Fast-forward 7 hours, I log in to wolfe-01 and this is the juju status:
> http://paste.ubuntu.com/7216852/
>
> I've attached the all-machines.log, which contains nil pointer errors.
>
> Unfortunately, I can't be sure what transpired on the machine during
> those 7 hours - only that I didn't touch anything.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/juju-core/+bug/1303787/+subscriptions

Dave Cheney (dave-cheney) wrote :

Here is my script to create the test environment.

http://paste.ubuntu.com/7219530/

Dave Cheney (dave-cheney) wrote :

Yup. I can reproduce this error. I'm spinning up an amd64 trusty image to see if the problem is isolated to ppc64l

Changed in juju-core:
status: Incomplete → Triaged
Curtis Hovey (sinzui) on 2014-04-14
Changed in juju-core:
milestone: 1.19.0 → 1.19.1
Curtis Hovey (sinzui) on 2014-04-17
Changed in juju-core:
milestone: 1.19.1 → 1.20.0
Changed in juju-core:
milestone: 1.20.0 → next-stable
Curtis Hovey (sinzui) on 2014-10-28
Changed in juju-core:
importance: High → Medium
milestone: next-stable → none
Tim Penhey (thumper) on 2015-09-30
Changed in juju-core:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers