mongodb with --ssl not available in precise

Reported by Marco Ceppi on 2013-07-22
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
juju-core
Medium
Unassigned

Bug Description

The mongodb-server package in precise doesn't support SSL, as a result local provider fails with

error command line: unknown option sslOnNormalPorts
use --help for help

During the juju-db upstart task.

Chris J Arges (arges) wrote :

Backporting mongodb 1:2.2.4-0ubuntu1 from raring allows the bootstrap command to work.

Marco Ceppi (marcoceppi) on 2013-07-31
tags: added: papercut
Nick Veitch (evilnick) on 2013-07-31
tags: added: doc
Antonio Rosales (a.rosales) wrote :

The local provider story also needs to be evaluated on precise. I think the lxc packaging may be a little old for local provider to work.

-thanks,
Antonio

Dave Cheney (dave-cheney) wrote :

This is strange. If you install juju-core 1.12 from ppa:juju/stable then you also have the correct mongodb dep in that ppa.

I guess there is an ordering issue, and juju-core doesn't depend or recommend mongodb, that is something we can fix.

BUT, lxc + precise == sadface so fixing the mongo dependency is only going to lead folks further astray.

On balance I would prefer to see the local provider from working on precise rather than fixing the monodb problems.

John A Meinel (jameinel) wrote :

To run the local stuff you install "juju-local" which *does* have a dependency on LXC and mongodb.

Also, the plan is that either ppa:juju/stable or the Cloud Archive will get the updated LXC package (backported from whatever release).

I don't see it in there yet, but it is intended that we'll backport whatever LXC work we need to go along with 'juju-local'.

Changed in juju-core:
importance: Undecided → Medium
status: Confirmed → Triaged
John A Meinel (jameinel) wrote :

I should comment, we don't depend (yet) on features in LXC that are not in precise. But we would like to support some of the "go fast" bits that are only available in newer LXC. When we use them, we plan to make sure the LXC package is available for precise.

Changed in juju-core:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers